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Welcome to R:BASE Turbo V-8 for Windows

Welcome to the Next Generation R:BASE Turbo V-8 for Windows.
R:BASE is an Industrial-Strength, True 32-Bit, Multi-User Relational
Database. But R:BASE is not just a Database Management System;
it is a total GUI development environment for all Windows desktop
and network applications. R:BASE Turbo V-8 for Windows is the
ideal Database Management Suite for creating and maintaining your
mission critical data with a true graphical user interface. Since its
introduction in 1981 as the first PC-based database management
system based on Dr. Codd’s relational model, R:BASE has led as
the first 32-bit DBMS in its class, providing programming-free
application development, automatic multi-user capabilities, 4GL (a
full-featured programming language in the R:BASE base product)
and embedded ANSI SQL. And now with R:BASE Turbo V-8 for
Windows, we have added a whole new look and feel to enhance the
applications you develop in R:BASE. You can rapidly produce the
type of results that previously would have required various third
party development tools. Simply using native controls, you can now
design cool applications at a fraction of the cost and development
time when compared to other database and development tools
available.results that previously would have required various third
party development tools.
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1 Preparation

When preparing to convert a legacy database and use those files in R:BASE Turbo V-8, it is important that you
follow the proper steps to convert that database. Please review the following steps and recommendations to
ensure you convert your legacy database(s) successfully.

1.1 Make a Database Backup

Before you begin, make a backup copy of your database. You should place the database on a storage medium
that is different than the one which your original files are already stored upon. For example, if you are using a
hard disk to store the data, you can back up your database to an external hard drive, a flash drive, a tape
drive, or a CD-ROM. With these storage options, you can also copy the backup files back to your hard drive.

If users are still entering data into the live database, while the conversion is taking place, use a different
database copy than the one in use. When the conversion is complete, the live data being added to can always
be loaded into the converted database at a later time. Make sure no users are connected to the database when
the copy is made.

During the conversion process, it is also recommended to make periodic backups. This will prevent you from
starting from the beginning in case any problems occur.

1.2 Review Table and Column Names

You must review all table and column names to be sure that no invalid names are defined and no reserved
words are used.

In the current version, a 1-18 character alpha-numeric name must be specified for a column. Spaces are NOT
permitted. Valid names must start with an alpha character and can include the following symbols:

· Letters (A-Z)
· Numbers (0-9)
· _ (underscore)
· # (pound sign) *
· $ (dollar sign) *
· % (percent sign) *

*Note: For ODBC compliance, it is NOT recommended to use the #, $, or % even though R:BASE permits
it.

Review your table and column names that may begin with a number. Check for any characters that are not
supported like a question mark "?" or a greater than character ">".

Also review your table and column names to verify that no reserved words are used. These words, commands,
keywords, and other names are to be used exclusively by the R:BASE database. Names used by System
Tables, System Views and System Columns are also reserved words. As a rule, all words beginning with "SYS"
are reserved.

Do not use reserved words or any shorter forms of them as names for columns, tables, or views. As a rule, if
the word is a reserved word, R:BASE will flag it. R:BASE will not allow you to use a reserved word as a column
or table name, but this MAY NOT always be the case. For example in the table designer, R:BASE may not warn
you about REF, short for REFERENCES, but REF will not be allowed in a command file. If a particular column
or table is giving you problems, please check out the list below and consider all shortened versions of the
words listed here.

The following is a list of all known reserved words, commands, keywords, and other names that are in effect
when ANSI is set on, which is the default setting.
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ABORT
ABS
ABSOLUTE
ACOS
ADA
ADD
AINT
ALL
ALTER
AND
ANINT
ANSI
ANY
APPEND
AS
ASC
ASCII
ASIN
ASSIGN
AT
ATAN
ATAN2
ATT
ATTACH
AUTHORIZATION
AUTHORIZE
AUTOCHK
AUTOCOMMIT
AUTOCONVERT
AUTODROP
AUTONUM
AUTONUMBER
AUTORECOVER
AUTOROWVER
AUTOSKIP
AUTOSYNC
AUTOUPGRADE
AVERAGE
AVG
BACKGRND
BACKUP
BEEP
BEGIN
BEGINS
BELL
BETWEEN
BIT
BITNOTE
BLINK
BLINKING
BOTH
BREAK
BRND
BROWSE
BUILD
BY
C
CALL
CASCADE
CASE
CASEP
CD
CGA
CENTURY
CHANGE
CHAR
CHARACTER

CHDIR
CHDRV
CHECK
CHKDSK
CHKKEY
CHOOSE
CLEAR
CLOSE
CLS
COBOL
CODELOCK
COLLATE
COLLATEC
COLOR
COLUMN
COLUMNS
COMMENT
COMMIT
COMPUTE
COMPUTED
CONNECT
CONSTRAINT
CONTAINS
CONTINUE
COPY
COS
COSH
COUNT
CREATE
CROSSTAB
CTR
CTXT
CURRENCY
CURRENT
CURSOR
CURSORS
CVAL
DAT
DATA
DATE
DATETIME
DEBUG
DECIMAL
DECLARE
DEFAULT
DEFINE
DELETE
DESC
DETACH
DEXTRACT
DIALOG
DIM
DIR
DISCONNECT
DISPLAY
DISTINCT
DOUBLE
DRAW
DROP
DUPLICAT
DUPLICATE
ECHO
EDIT
EDITOR
ELSE
END
ENDC

ENDIF
ENDS
ENDSW
ENDWHILE
ENTER
ENVVAL
EQ
EQNULL
ERASE
ERROR
ESC
ESCAPE
EXCEPT
EXECUTE
EXISTS
EXIT
EXP
EXPAND
EXPLODE
EXPRESS
FAILS
FASTFK
FASTLOCK
FEEDBACK
FETCH
FILES
FILL
FILLIN
FIRST
FLOAT
FLUSH
FOLD
FOR
FOREGRND
FOREIGN
FORMAT
FORMATTED
FORMS
FORTRAN
FOUND
FROM
FULL
FV1
FV2
GATEWAY
GE
GET
GETDATE
GETKEY
GETVAL
GO
GOTO
GRANT
GROUPED
GT
HAVING
HEADING
HEADINGS
HELP
ICAP1
ICAP2
ICHAR
IDAY
IDWK
IF
IFEQ
IFGT

IFLT
IFRC
IHASH
IHR
IMIN
IMON
IN
INDEX
INDICATOR
INI
INITPOS
INPUT
INSERT
INT
INTEGER
INTENSITY
INTERSECT
INTERVAL
INTO
IS
ISEC
ISTAT
IYR
IYR4
JDATE
JOIN
KEY
KEYBOARD
KEYMAP
LABEL
LANGUAGE
LAST
LASTKEY
LAUNCH
LAVG
LAYOUT
LBLPRINT
LCFOLD
LE
LIKE
LIMIT
LINEEND
LINES
LIST
LISTATT
LISTREL
LJS
LMAX
LMIN
LOAD
LOCK
LOG
LOG10
LOOKUP
LOOKUPS
LT
LUC
MANOPT
MAX
MAXIMUM
MAXTRANS
MD
MENU
MESSAGES
MIN
MINIMUM
MKDIR

MOD
MODULE
MOUSE
MOVE
MPW
MULTI
NAME
NE
NEW
NEWPAGE
NEWROW
NEXT
NEXTROW
NEXTTAB
NINT
NOCHECK
NOECHO
NOFILL
NOHEADER
NONE
NONUM
NOT
NOTE
NOTE_PAD
NULL
NUM
NUMERIC
OF
OFF
ON
OPEN
OPTION
OPTIONS
OR
ORDER
OUTER
OUTPUT
OWNER
PACK
PAGE
PAGEMODE
PAGEROW
PASCAL
PASSTAB
PASSTHROUGH
PAUSE
PLAYBACK
PLI
PLUGINS
PMT1
PMT2
POINTER
PRECISION
PREF
PREFIX
PREVROW
PREVTAB
PRIMARY
PRINT
PRINTER
PRIOR
PRIVILEGE
PRNSETUP
PROC
PROCEDURE
PROJECT
PROMPT
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PROMPTS
PROPERTY
PUBLIC
PUT
PV1
PV2
QBE
QUALCOLS
QUERY
QUIT
RATE1
RATE2
RATE3
RBAPP
RBBEDIT
RBDEFINE
RBEDIT
RBGSIZE
RBLABELS
RBSYNC
RBSYSTEM
RD
RDATE
READ
READ/WRITE
REAL
RECALC
RECORD
RED
REDEFINE
REFERENCES
REFRESH
RELATIVE
RELOAD
REMOVE
RENAME
REPORTS
RESET
RESTORE
RETURN
REVERSE
REVOKE
RHIDE
RJS
RMDIR
ROLLBACK
ROUND
ROW
ROWLOCKS
RPHONE
RPW
RSHOW
RTIME
RULES
RUN

SATTACH
SAVEROW
SCHEMA
SCONNECT
SCRATCH
SCREEN
SCROLL
SDETACH
SECTION
SELECT
SELMARGIN
SEQUENCE
SERVER
SET
SFIL
SGET
SHOW
SIGN
SIN
SINH
SKIP
SLEN
SLOC
SMALLINT
SMOVE
SNAP
SOME
SORT
SORTED
SOUNDS
SOUNDS_L
SOUNDS_LIKE
SPUT
SQLCODE
SQLERROR
SQRT
SRPL
SSQL
SSUB
STARTUP
STATICDB
STDEV
STORE
STRIM
STRUCTURE
SUB
SUBTRACT
SUFFIX
SUM
SWITCH
SYS
TABLE
TABLES
TABSIZE
TALLY

TAN
TANH
TDWK
TERM1
TERM2
TERM3
TERMINAL
TEXT
TEXTRACT
TIME
TIMEOUT
TITLE
TMON
TO
TOLERANCE
TRACE
TRANSACT
TRIG
TYPE
UDF
ULC
UNION
UNIQUE
UNLOAD
UNNAMED
UPDATE
UPGRADE
USER
USERAPP
USING
VALUES
VARBIT
VARCHAR
VARIABLE
VARIANCE
VERIFY
VERSION
VIEW
VIEWS
WAIT
WALKMENU
WHENEVER
WHERE
WHILE
WHILEOPT
WIDTH
WITH
WORK
WRAP
WRITE
YEAR
ZERO
ZIP

If you are still using a legacy version of R:BASE, it is recommended that you perform these table and column
name changes in that version. After making the table and column names changes, R:BASE will update the
form, report, and label column objects with the appropriate new name. However, if any of the columns and
tables are listed in the form, report, and label variable expressions, you must manually edit these expressions.

On paper, record any table and column name changes. Later in the conversion process when you're updating
your command files, you will need to make these necessary name changes for the command files as well.
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1.3 Conversion Tools

The Manual Tools and a Single Seat of R:BASE 6.5++ for Windows are included in the Full Version of R:BASE
Turbo V-8 for Windows, for conversion purposes. The files and installer are located on the root of the R:BASE
Turbo V-8 for Windows CD-ROM in the "Conversion Tools" folder. The executable programs in the "CONVERT"
directory are only used for converting databases that are older than R:BASE 4.5.

Convert Express is a separate product and is sold separately. Convert Express is only used with R:BASE 2.11,
or earlier, databases. Or, if your R:BASE database version is 3.x or 4.0, and you do not wish to save your
forms and reports, then Convert Express will serve your needs. Please call R:BASE Technologies at
1+724.733.0053 or e-mail sales@rbase.com, if you wish to purchase Convert Express.
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2 Starting With the Database Files

2.1 Recognizing the Database Files

When locating and using the database name in the conversion instructions, be sure to remember that the
"actual" database name for .RBS and .RBF files does not include the "1", "2", or "3", which is located before
the file extension. For example, a R:BASE 3.1 database with the name SALES will have the database files
SALES1.RBF, SALES2.RBF, and SALES3.RBF, but the database name is still just "SALES". In the steps below
where the "dbname" is required in the command syntax, use only the "actual" database name.

To use this document you will need to know which version of R:BASE you are upgrading from. To assist you in
getting a rough idea of which version you are starting at, we have included the table below which lists the
various R:BASE file formats. Once you find your R:BASE database version from the table below, follow the
necessary conversion steps in the next section.

R:BASE Database File Formats

4000 / 5000 System V to 4.0

DBNAME1.RBS DBNAME1.RBF

DBNAME2.RBS DBNAME2.RBF

DBNAME3.RBS DBNAME3.RBF

4.5 to 5.0 5.5 to 7.6

DBNAME.RB1 DBNAME.RB1

DBNAME.RB2 DBNAME.RB2

DBNAME.RB3 DBNAME.RB3

DBNAME.RB4

Turbo V-8

DBNAME.RX1

DBNAME.RX2

DBNAME.RX3

DBNAME.RX4

2.2 Conversion Steps

PLEASE REMEMBER TO BACK UP YOUR DATABASE!

The steps required to convert legacy databases to work with R:BASE Turbo V-8 for Windows are described in
the following flow chart. Locate your current R:BASE database file version below and complete the steps until
you reach the bottom. If you are not sure of your database file version, refer to the above chart.
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2.2.1 R:BASE 4.0 and Lower Versions

If you are converting a database from R:BASE 4.0 or lower, you must first following the below instructions,
then proceed to either the "Manual Tools" or "Convert Express" based on the products you are licensed for. If
you did not buy Convert Express, then go to the "Manual Tools".

If you are converting a database at version R:BASE 4.5 and higher or 6.5++ and lower, then proceed to the
steps listed at "R:BASE 4.5 and Higher Versions".
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All Databases at  Version 4.0 and Lower:

1. Create a new directory; perhaps something near your root directory on the local drive (example:
"C:\DBTEMP").

2. Copy the contents of the "CONVERT" directory, from the installation CD, to your new directory.
3. Copy your database files to the new directory.
4. Continue with your version as listed below.

2.2.1.1 Manual Tools

Start at your R:BASE database version, in the bold font.

R:BASE 4000 / R:BASE 5000

1. Open a Command Prompt or DOS Prompt window and navigate to the new directory
2. At the Prompt, type: CONVERT dbname
3. Repeat for all databases
4. Continue with the steps listed at "R:BASE System V, 2.x and 3.x"

R:BASE System V, 2.x and 3.x

1. If you have not done so already, open a Command Prompt or DOS Prompt window and navigate to
the new directory

2. At the Prompt, type: DBCONV dbname
3. Repeat for all databases
4. Continue with the steps listed at "R:BASE 3.x and 4.0"

R:BASE 3.x or 4.0

1. If you have not done so already, open a Command Prompt or DOS Prompt window and navigate to
the new directory

2. At the Prompt, type: NEWDB dbname
3. Repeat for all databases
4. Continue with the steps listed at "R:BASE 4.5 through 6.5 Versions"

You can exit the Command Prompt or DOS Prompt window now. Use the EXIT command to exit.

2.2.1.2 Convert Express

Start at your R:BASE database version, in the bold font.

R:BASE 4000 / R:BASE 5000

1. Open a Command Prompt or DOS Prompt window and navigate to the new directory
2. At the Prompt, type: CONVERT dbname
3. Repeat for all databases
4. Continue with the steps listed at "R:BASE System V, 2.x and 3.x"

R:BASE System V, 2.x, 3.x, or 4.0

1. If you have not done so already, open a Command Prompt or DOS Prompt window and navigate to
the new directory

2. At the Prompt, type: CONVEX
3. Select CONVERT DATABASES
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4. Select ALL FOUND
5. Continue with the steps listed at "R:BASE 4.5 through 6.5 Versions"

2.2.2 R:BASE 4.5 through 6.5 Versions

At this point, you must have R:BASE 6.5++ installed on your computer. A Single Seat of R:BASE 6.5++ for
Windows is included with the Full Version of R:BASE Turbo V-8 for Windows, for conversion purposes. The
installer is located on the root of the R:BASE Turbo V-8 for Windows CD ROM in the "Conversion Tools" folder.

Before attempting to connect to your pre-R:BASE Turbo V-8 for Windows database for the first time, you will
need to following these instructions to ensure proper conversion:

If there is no OWNER or Password

1. Install and launch R:BASE 6.5++
2. Navigate to your database directory using the "Browse for Folder" button (bottom left corner, folder

icon with a green arrow)
3. Go to the R> Prompt window (third button from the left on the Tool Bar, or press [Ctrl]+[R]
4. At the R> Prompt, type:  SET MULTI OFF , then press [Enter]

5. At the R> Prompt, type:  SET STATICDB OFF , then press [Enter]

6. At the R> Prompt, type:  SET AUTOUPGRADE ON  , then press [Enter]

7. At the R> Prompt, type:  SET AUTOCONVERT ON , then press [Enter]

8. At the R> Prompt, type:  CONNECT DBNAME  , then press [Enter]

9. At the R> Prompt, type:  SET IDQUOTES=` , then press [Enter]  (the ` quote character is the

reverse single quote, which is next to the "1" and under the tilde "~", on American keyboards
10. At the R> Prompt, type:  DISCONNECT , then press [Enter]

11. Repeat "Steps 8-10" for all databases
12. Continue with the Housekeeping chapter

If there is a Username and Password

1. Install and launch R:BASE 6.5++
2. Navigate to your database directory using the "Browse for Folder" button (bottom left corner, folder

icon with a green arrow)
3. Go to the R> Prompt window (third button from the left on the Tool Bar, or press [Ctrl]+[R]
4. At the R> Prompt, type:  SET MULTI OFF , then press [Enter]

5. At the R> Prompt, type:  SET STATICDB OFF , then press [Enter]

6. At the R> Prompt, type:  SET AUTOUPGRADE ON  , then press [Enter]

7. At the R> Prompt, type:  SET AUTOCONVERT ON , then press [Enter]

8. At the R> Prompt, type:  CONNECT DBNAME IDENTIFIED BY Username Password , then press

[Enter]
9. At the R> Prompt, type:  SET IDQUOTES=` , then press [Enter]  (the ` quote character is the

reverse single quote, which is next to the "1" and under the tilde "~", on American keyboards
10. At the R> Prompt, type:  DISCONNECT , then press [Enter]

11. Repeat "Steps 8-10" for all databases
12. Continue with the Housekeeping chapter

If there is an Owner

1. Install and launch R:BASE 6.5++
2. Navigate to your database directory using the "Browse for Folder" button (bottom left corner, folder

icon with a green arrow)
3. Go to the R> Prompt window (third button from the left on the Tool Bar, or press [Ctrl]+[R]
4. At the R> Prompt, type:  SET MULTI OFF , then press [Enter]

5. At the R> Prompt, type:  SET STATICDB OFF , then press [Enter]

6. At the R> Prompt, type:  SET AUTOUPGRADE ON  , then press [Enter]

7. At the R> Prompt, type:  SET AUTOCONVERT ON , then press [Enter]

8. At the R> Prompt, type:  SET USER Ownername , then press [Enter]

9. At the R> Prompt, type:  CONNECT DBNAME , then press [Enter]

10. At the R> Prompt, type:  SET IDQUOTES=` , then press [Enter]  (the ` quote character is the

reverse single quote, which is next to the "1" and under the tilde "~", on American keyboards
11. At the R> Prompt, type:  DISCONNECT , then press [Enter]

12. Repeat "Steps 8-11" for all databases
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13. Continue with the Housekeeping chapter

2.2.2.1 Housekeeping

The following will create a copy of the database that is completely rebuild with the structure, data, and
indexes reloaded. It's one of the very basic but very useful housekeeping tools. It is similar to the PACK
command (or defragmenting a hard drive).

These steps must be typed in at the R> Prompt, followed by the [Enter] key:

1. DISCONNECT
2. RENAME OrigName.RB* BckupDB.RB*
3. CONNECT BckupDB
4. RELOAD OrigName

Continue below to check your database for ODBC compliance.

2.2.2.2 ODBC Compliance

If you are planning on using ODBC to import and export data from R:BASE, at this section you must make
sure that your characters are set correctly by doing the following:

1. Go to an R> Prompt
2. Connect to your Database
3. Type SHOW CHAR
4. Compare your values to the chart below

Character Set To Description

MANY % Percent Sign

SINGLE _ Underscore

QUOTES ' Single Quote

IDQUOTES ` *Reverse Single Quote

* On American keyboards, this is usually located under the tilde "~", which is next to the 1

5. If they do not match, change them by typing SET TYPE=CHAR
(where TYPE is from the "Character" column and CHAR from the "Set To" column)

For example, SET MANY=%

Continue below to insure your database files are Y2K compliant.

2.2.2.3 Y2K Compliance

For more information on Y2K Compliance please visit our Y2K Page at http://www.rbase.com/support/y2k/

To check the Y2K compliance of your database do the following.

1. Go to an R> Prompt
2. Connect to your Database
3. Type SHOW DATE

Most likely the settings will be as follows... (This is the default for upgraded databases).

DATE FORMAT MM/DD/YY
DATE SEQUENCE MMDDYY
DATE CENTURY 19

http://www.rbase.com/support/y2k/
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DATE YEAR 0

If so, then your database is NOT Y2K compliant. To activate the Y2K compliancy features of your database we
recommend the following:

Set your Format to 4 Y's

When they are set that way then 1/1/1999 will be seen as a valid year and 1/1/99 will also be a valid year.
If you are set to 2 Y's then only 1/1/99 will be a valid year.

Set the Date Year to a Convenient Year

The Date Century and Date Year determine how 2 digit years such as 1/1/99 are handled. To determine
your settings mentally combine the century and the year (in this case 19 and 0 make 1900) and then add
99 (in this case 1999) all two digit years will be interpreted as being between these dates. Setting Date
Year to 80 will result in 19 + 80 giving 1980 and then adding 99 making 2079. Thus all two digit dates will
be between 1980 and 2079. For example a date entered as 1/1/60 would be seen as 2060.

Older versions set to four Y's would see 2 digit dates as being complete four digit years. For example,
1/1/99 would be January First in the year 99. This is known as First Century data. For this reason if your
database is already set to four Y's on the format we recommend using the following command to check for
invalid dates:

TALLY datecol FROM tablename WHERE datecol < 1/1/1950

This should build a list of all dates (and how often they occur) that are possibly incorrectly entered and that
you can then deal with. Be careful not to go overboard. For example: if you have your family tree stored in
an R:BASE Database then be careful that you leave Great Grandmother's birthday in the 1800's where it is
supposed to be even though the Tally command above would flag that as an "invalid" date.

2.2.2.4 Converting Forms, Reports, & Labels

At this point, if you reviewed and followed the steps provided in the conversion process, you will have four
database files, where you can see your tables listed in the R:BASE Turbo V-8 Database Explorer window. You
should also be able to browse the table data with no problem.

You must now decide whether or not you will convert your existing Forms, Reports, and Labels to R:BASE
Turbo V-8 for Windows. If you are already using a Windows version of R:BASE, then it is very likely that you
will convert the Forms, Reports, and Labels to save time. If you are upgrading from a DOS version of R:BASE
you can convert the Forms, Reports, and Labels, or create new ones in the Windows version.

Will you be converting your Forms, Reports, and Labels?

· If the answer is: "No," then you can begin using R:BASE Turbo V-8 to design new Forms, Reports, and
Labels. If you have not done so already, begin with the R:BASE Tutorial to learn the fastest methods to
create and design your forms and reports. The Tutorial is available directly from the R:BASE main Menu Bar
under "Help" > "R:BASE Tutorial".

· If the answer is: "Yes," and if your database is being upgraded from DOS or is not currently at the 6.5++
version for Windows, you will need to take several necessary conversion steps to migrate the Forms,
Reports, and Labels to the 6.5++ version. If you are already using R:BASE 6.5++ for Windows, go directly
to "R:BASE 6.5++ and Higher Versions".

As you are planning to convert your existing Windows Forms, Reports, and Labels from your pre-6.5++
database, you will need to open EACH Form, Report, and Label in the respective designer (Form Designer,
Report Designer, Label Designer) in the R:BASE 6.5++ for Windows version, make a slight change (like
moving an object), and then save your changes.

By saving the changes in 6.5++ you are setting a version flag which allows the R:BASE Turbo V-8 Form
Designers, Report Designers, Label Designers to properly convert the item.

There is no way to automatically convert all of your Forms, Reports, and Labels to 6.5++. They must all be
opened, saved, and closed individually.
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Procede to the next chapter for converting "Legacy Forms, Reports, & Labels".

2.2.2.4.1  6.5 and Lower Forms, Reports, & Labels

At this point, you must have R:BASE 6.5++ installed on your computer. A Single Seat of R:BASE 6.5++ for
Windows is included with the Full Version of R:BASE Turbo V-8 for Windows, for conversion purposes. The
installer is located on the root of the R:BASE Turbo V-8 for Windows CD ROM in the "Conversion Tools" folder.

DOS to Windows Users

When you convert a form, report, or label, you can have R:BASE format it automatically for you. If you
choose to "Autoformat" the form, report, or label, R:BASE 6.5++ will resize the fields vertically and moves
them so that they are visible and do not overlap one another, based upon your default settings. This step
will save you a considerable amount of time in the DOS to Windows conversion.

Before you begin the "Conversion Steps" below, first define your default settings in R:BASE 6.5++.

Defining R:BASE 6.5++ Default Settings

Specify global default settings for objects in forms, reports, and labels using the "Preferences" dialog box.

1. Launch R:BASE 6.5++ for Windows
2. Connect to your database by selecting "File" > "Connect to Database..." from the main Menu Bar.

You will be prompted to locate your database files where they are stored on your computer. Once
connected to your database, you will see the database name listed in the R:BASE 6.5++ program
caption in brackets.

3. From the main Menu Bar, select "Utilities" > "Preferences".

The "Preferences" dialog window will appear. Within the "Designer Defaults" panel, a separate button
for "Forms...", "Reports...", and "Labels..." is displayed.

4. Choose the button "Forms..."

The "Forms Settings" dialog will appear. There are three buttons that require your attention: "Column
Objects", "Variable Objects", and "Text Objects".

5. Choose the "Column Objects" button.

The "Column Objects Properties" dialog will appear.

6. Choose the "Font..." button.

The default value for the font is "MS Sans Serif", "Regular", "8".

7. Change the font name, style and size to something more legible for the conversion. (i.e. "Arial", "Bold",
"12" or... "Times New Roman", "Bold", "12")

8. Click the "OK" button, then the "OK" button again.
9. Repeat the same font name, style and size for your form "Variable Objects" and "Text Objects".
10. Return to the "Preferences" dialog and repeat the same font changes for "Reports" and "Labels",

covering the "Column Objects", "Variable Objects", and "Text Objects" in each.

Note: You can skip setting up the defaults for any Designer if you do not use that part of R:BASE. For
example, if you don't have any labels to convert, then you do not have to set up your Label defaults.

Conversion Steps

1. Launch R:BASE 6.5++ for Windows, if you have not done so already.
2. Connect to your database by selecting "File" > "Connect to Database..." from the main Menu Bar.

You will be prompted to locate your database files where they are stored on your computer. Once
connected to your database, you will see the database name listed in the R:BASE 6.5++ program
caption in brackets.
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3. Open the Object Manager, if it is not already displayed. (select the first icon on the tool bar that looks
like an octopus).

You will see several tabs across the top of the Object Manager; "Apps", "Databases", etc.

4. Click on the "Database" tab and you should see your database(s) listed.
5. Select the "Open" if you are not actually connected to your database.

When you are connected to your database, the other tabs will become enabled.

6. Select the "Reports" tab.

Your list of R:BASE reports will be displayed, if any are defined.

7. Highlight the first item in the list, by clicking on it, and click the "Design" button.

At this point you may see three different "Yes"/"No" dialog confirmations based on whether you are
converting from DOS to Windows and what types of objects are located on the form/report/label.

8. When you are prompted, "Do you wish to upgrade?", select "Yes".

9. When you are prompted, "Do you wish to auto-format?", select "Yes".

This will perform the automatic conversion of the DOS item based upon default settings.
IMPORTANT: Make sure you have set up the "Defining R:BASE 6.5++ Default Settings" as
described above.

10. You may be asked to change double lines to single lines, which is your decision. It really does not
make any difference as the items will likely be replaced with more Windows-friendly visually appealing
items.

The report will now be displayed. If you are upgrading from 6.1, or 6.5, you will not see any dialo0g
message, but are required to make a slight adjustment to any object on the report.

11. Now, close the report and save your changes.

If any error messages are displayed when you save the report, it is recommended that you take care
of them now before continuing.

Possible reasons that an error message is displayed include:
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Error Message Problem Possible Solution

Error in Expressions. Fix Expressions
before saving.

There may be a variable based upon
another variable that is not defined.

At the R:BASE R> Prompt,
use the SHOW VARIABLE
command to list defined
global variables. Then, to
define a new global variable,
use the SET VARIABLE
command.

If there are several variables
that need defined for the
entire conversion process,
create a command file to
store all needed SET
VARIABLE commands.

Error in Expressions. Fix Expressions
before saving.

There may be a lookup variable based
upon a column name that has
changed.

If you have renamed a
column or a column was
renamed through the
conversion process due to an
illegal column name, and that
column is used in a lookup
variable on this report, you
must alter the column name
in the variable expression and
save your changes.

Error in Expressions. May not save
properly. Continue Saving?

Variables that perform calculations or
combine a number of values are not
enclosed in parenthesis.

For variables like the one
below,

vTotal = price *
quantity

add parenthesis as follows:

vTotal = (price *
quantity)

Error in Expressions. Placed variables
may have been lost.

If you do not fix your expressions, by
adding parenthesis around calculations,
and then save your changes, you run
the risk of losing the variable objects
as they were placed on your report,
form, or label.

You must correct the
expression value by adding
parenthesis, then place the
variable(s) on the report
again.

"Unrecognized column in expression.",
followed by; "Expression cannot be
evaluated."

A text variable that combines a number
of values is using the incorrect QUOTES
setting.

If you changed your QUOTES
setting from double quotes (")
to single quotes ('), replace
any double quotes with single
quotes in the expressions
where quotes are used.

"Unrecognized column in expression.",
followed by; "Expression cannot be
evaluated."

A referenced variables may not be
dotted.

If a variable expression
contains other variables, be
sure to place a period before
the referenced variable so
R:BASE recognizes the
variable value, and not the
variable name.

While you are reviewing your report, be sure to review the following:

· variables should not display ERROR in place of the data type
· variables are assigned the correct data type (TEXT, INTEGER, etc.)
· your break definitions have valid variables/columns

Note: Don't spend too much time lining things up in the R:BASE 6.5++ designers. Only make
superficial changes. You will be able to make changes much easier in the newest Windows version.
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If any changes were made, save your changes and close the report.

12. Select the next report in the list and repeat Steps 7-11.
13. Once you are complete converting all of the reports, you will begin converting Forms by selecting the

"Forms" tab, and Labels by selecting the "Labels" tab. Launch each of the individual designers using
the "Design" button. Follow steps 7-11 above.

The resulting Forms, Reports, and Labels will be workable and SHOULD RUN, but not nearly what they can be!

The next step is to close R:BASE 6.5++ for Windows and open R:BASE Turbo V-8 for Windows.

2.2.3 R:BASE 6.5++ and Higher Versions

Before attempting to connect to your R:BASE database, you will need to following the below instructions to
ensure a proper conversion:

1. Install and launch R:BASE Turbo V-8
2. Navigate to your database directory using the "Browse for Folder" button (bottom left corner, folder

icon with a green arrow)
3. Go to the R> Prompt window (third button from the left on the Tool Bar, or press [Ctrl]+[R]
4. At the R> Prompt, type:  SET MULTI OFF , then press [Enter]

5. At the R> Prompt, type:  SET STATICDB OFF , then press [Enter]

6. At the R> Prompt, type:  TURBO DbName  , then press [Enter]

7. At the R> Prompt, type:  CONNECT DbName  , then press [Enter]

These steps will build a clean database to be used exclusively by R:BASE Turbo V-8!

The following alternative method is also available to convert your R:BASE 6.5++ or higher databases to
version Turbo V-8.

1. Connect to the database and open the R> Prompt with your 6.5++ or higher version.

2. Check the IDQUOTE settings of connected database.

At the R> Prompt, type:

SHOW CHARACTERS

Notice the last parameter, IDQUOTES

If IDQUOTES is set to NULL, you'll need to change NULL to the appropriate character, such as ` (reversed
quote) as following:

SET IDQUOTES= `

3. Unload the entire database.

At the R> Prompt, type:

SET NULL -0-
OUTPUT filename.ALL
UNLOAD ALL
OUTPUT SCREEN

This process will create two files (filename.ALL and filename.LOB)

4. Disconnect the database.

At the R> Prompt, type:

DISCONNECT

5. Now Start R:BASE Turbo V-8 (C:\RBTI\RBG8\RBG8.exe)
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Change directories where the "filename.ALL" and "filename.LOB files" are located. To do so, choose
"Utilities" > "Set Working Directory..." from the menu bar.

Next, at the R:BASE Turbo V-8 R> Prompt type:

RUN filename.ALL

These steps will build a clean database to be used exclusively by R:BASE Turbo V-8!

The first time you connect to your R:BASE Turbo V-8 database, the following additional system tables will
already be created:

· SYS_FORMS3
· SYS_LABELS3
· SYS_LAYOUTS3
· SYS_MERGE
· SYS_REPORTS3

To verify this, while connected to your database, type: LIST SYS_%

This is where the R:BASE Turbo V-8 objects are stored.

2.2.3.1 6.5++ Forms, Reports, & Labels

At this point in the database conversion process, you will either be a R:BASE 6.5++ for Windows user that has
just upgraded to Turbo V-8, or you have just converted all of your Forms, Reports, and Labels to version
6.5++ using the previous steps. To continue, you must have R:BASE Turbo V-8 for Windows installed on your
computer to complete the instructions below.

1. Launch R:BASE Turbo V-8 for Windows
2. Connect to your database by selecting "Database" > "Connect to Database..." from the main Menu

Bar.

You will be prompted to locate your database files where they are stored on your computer. Once
connected to your database, you will see the database name listed in the R:BASE Turbo V-8 program
caption in brackets.

Throughout the following instructions, there will be areas of the R:BASE interface that will require you to know
what is being referred to (i.e. Database Explorer, Group Bar, Tool Bar, Menu Bar, etc.). For a quick description
as to what these objects are, please read the "Introduction" page of the R:BASE Turbo V-8 Tutorial before
continuing.

To open the Introduction page, select "Help" > "R:BASE Tutorial" from the R:BASE main Menu Bar.

Once you have completed reading the introduction page, close the window and go to the next section,
Converting Forms.

2.2.3.1.1  Converting Forms

You should now be looking at the R:BASE window with the Database Explorer displayed. To confirm, you will
see the main R:BASE caption read the "R:BASE Turbo V-8", then your database name listed in square
brackets, then "R:BASE Database Explorer" listed in square brackets.

· If you do not see your database listed in brackets, then connect to it now by selecting "Database" >
"Connect to Database..." from the main Menu Bar. You will be prompted to locate your database files
where they are stored on your computer. Once connected to your database, you will see the database
name listed in the R:BASE Turbo V-8 program caption in brackets.

· If you do not see "R:BASE Database Explorer" listed in square brackets, then select the "Database
Explorer" button on the main Tool Bar. It is the first button on the left and the hint displayed will read
"Show Database Explorer".
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At the Database Explorer window, you will see the "Group Bar" listed on the left side of the window containing
various menu options of R:BASE database modules (i.e. Tables, Views, Forms, etc.)

1. Click on the "Forms" menu option of the Group Bar (figure 1) and select the "Convert" sub menu option
(figure 2).

(figure 1)

(figure 2)

Upon pressing this button, you will see that a dialog containing a list of the available forms is displayed
(figure 3).

(figure 3)

2. Select the form that you want to convert, and press the "OK" button.

3. If you are converting a multi-page form, you will be prompted to convert the form to either a single-
page form or a multi-tab form.
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With multi-page forms, you will want to convert it to a multi-tab form.

4. Select the "Convert to multi-tab form" option, and select the "Continue..." button.

The Form Designer will convert and launch the form in the designer.

At this point, you can now make changes to your form! However, since many of the issues and suggestions
refer to specific object names and require basic understanding of the Form Designer, it is recommended, that
you perform the conversions of the remaining modules (i.e. reports, labels), and then complete the R:BASE
Tutorial before continuing.

From the Main Menu, choose "Help" > "R:BASE Tutorial". This tutorial covers step-by-step instructions on
building a complete database and application from scratch providing the R:BASE relational logic as it adhere's
to Dr. Codd's relational model. This is where one would initially learn how to quickly adapt to the R:BASE
interface!

2.2.3.1.1.1  Issues and Suggestions

From this point in the conversion process, you can now make the necessary improvements on your existing
form design, and consider the listed suggestions.

NOTE: From inside the Form Designer, you can launch the Form Designer help file by pressing the
[Shift]+[F1] hot keys.

· Scrolling Regions
All regions in forms are converted to Scrolling Regions in the new R:BASE Turbo V-8 form. If you have
applied a color to a region from a DOS-version form, the region will be outlined with boxes.

When existing form regions are converted to Scrolling Regions in the Turbo V-8 version, any Text Label
contained on the region will be placed behind the scrolling region after the conversion. You will need to
manually move these objects from behind the scrolling region back to the front in the R:BASE Turbo V-8
Form Designer after the conversion of the form. Moving these object can be done easily by selecting the
objects, and using Cut [Ctrl]+[X] & Paste [Ctrl]+[V] to place the objects back on the region. Be sure to set
the focus on the region (select it with cursor) before the pasting the object.

· Push Buttons
When converting existing multiple page forms to R:BASE Turbo V-8, if you use Push Buttons with a
predefined Next Page or Previous Page EEP, these buttons will appear on the Turbo V-8 form, but will have
no action assigned to them. This is because of the Tab Control behavior which is used in R:BASE Turbo V-8
to create multiple page forms.

· Lookup Variables
The "Lookup Variable" is now really a "Lookup Variable", not to be changed. All expressions (if based on
lookup variables) are evaluated CORRECTLY and refresh INSTANTLY. Prior to version 7.x, that was not the
case. You had to issue the RECALC command every time you wanted to refresh your variables. If you wish
to achieve the same results in Turbo V-8, then DO NOT use form defined expressions, but rather EEPs which
can fire when you want and have the freedom to change the variables accordingly.

Example:
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1. In the Form Designer, you can create an Exit EEP on the column/variable before the look
column/variable field.
2. Exit EEP should do all the lookup for that column/variable.
3. Once the value is placed, now you can do whatever you want to change it or keep that same value.

· Lookup Variable Tip
Recently added to the R:BASE Turbo V-8 Form Designer was the option to run a command file (or action) for
a form before the Form Designer is launched. In the Form Designer, choose "Layout" from the Menu bar, the
select "On Before Design Action...".

This allows you to create any variables that Lookup Variables are based upon to avoid annoying error
messages when the form is opened in the designer. An example of a lookup variable based upon another
variable would be...

1 : TEXT    vCompany = Company IN Customer WHERE CustID = .vCustID

The error message appears because the variable vCustID is not defined. Adding the SET VAR command
following to the "On Before Design Action..." will alleviate this error message:

SET VAR vCustID INTEGER

The "On Before Design Action..." is listed under "Layout" on the main Menu Bar.

· Form Variables
Form variables that perform calculations or combine a number of values should be enclosed in parenthesis.
If you are getting an error messages for a variables performing calculations, like the one below,

2 : CURRENCY    vTotal = price * quantity

add parenthesis as follows:

2 : CURRENCY    vTotal = (price * quantity)

To learn more about the new Form Designer and Form Controls, please review the Help File [Shift]+[F1].

And, if you have not done so already, complete the R:BASE Tutorial in its entirety.

From the Main Menu, choose "Help" > "R:BASE Tutorial". This tutorial covers step-by-step instructions on
building a complete database and application from scratch providing the R:BASE relational logic as it adhere's
to Dr. Codd's relational model. This is where one would initially learn how to quickly adapt to the R:BASE
interface!

2.2.3.1.2  Converting Reports

You should now be looking at the R:BASE window with the Database Explorer displayed. To confirm, you will
see the main R:BASE caption read the "R:BASE Turbo V-8", then your database name listed in square
brackets, then "R:BASE Database Explorer" listed in square brackets.

· If you do not see your database listed in brackets, then connect to it now by selecting "Database" >
"Connect to Database..." from the main Menu Bar. You will be prompted to locate your database files
where they are stored on your computer. Once connected to your database, you will see the database
name listed in the R:BASE Turbo V-8 program caption in brackets.

· If you do not see "R:BASE Database Explorer" listed in square brackets, then select the "Database
Explorer" button on the main Tool Bar. It is the first button on the left and the hint displayed will read
"Show Database Explorer".

At the Database Explorer window, you will see the "Group Bar" listed on the left side of the window containing
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various menu options of R:BASE database modules (i.e. Tables, Views, Forms, etc.)

1. Click on the "Reports" menu option of the Group Bar (figure 1) and select the "Convert" sub menu
option (figure 2).

(figure 1)

(figure 2)

Upon pressing this button, you will see that a dialog containing a list of the available reports is
displayed (figure 3).

(figure 3)

2. Select the report that you want to convert, and press the "OK" button.

The Report Designer will convert and launch the report in the designer.

At this point, you can now make changes to your report! However, since many of the issues and suggestions
refer to specific object names and require basic understanding of the Report Designer, it is recommended, that
you perform the conversions of the remaining modules (i.e. forms, labels), and then complete the R:BASE
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Tutorial before continuing.

From the Main Menu, choose "Help" > "R:BASE Tutorial". This tutorial covers step-by-step instructions on
building a complete database and application from scratch providing the R:BASE relational logic as it adhere's
to Dr. Codd's relational model. This is where one would initially learn how to quickly adapt to the R:BASE
interface!

2.2.3.1.2.1  Issues and Suggestions

From this point in the conversion process, you can now make the necessary improvements on your existing
report design, and consider the listed suggestions.

NOTE: From inside the Report Designer, you can launch the Report Designer help file by pressing the
[Shift]+[F1] hot keys.

· Sub-Totals and Totals
To calculate sub-totals and totals of table columns, Aggregate Variables have always been used to perform
this job. Now, the R:BASE Turbo V-8 for Windows Report Designer has a built-in object called DBCalc, which
performs these same functions on table columns without creating the extra overhead of variables. You can
replace your Variable Label objects with DBCalc objects in instances where the Variables Object results will
not be used further down in the report.

· #DATE, #TIME, #PAGE, Document, and Page Information
R:BASE Turbo V-8 for Windows Report Designer now has an object called System Variable, which allows you
to place the current DATE, TIME, Document Name, Print DATE and TIME, or one of five Page Numbering
options. You should delete any Variable Label objects whose expression value consists of a System Variable
(#DATE, #TIME) and replace that object with a System Variable object. If you have any Variable Label
objects whose expression value consists of the #PAGE System Variable you must delete the variable object
and replace that object with a System Variable object.

· Lookup Variable Tip
Recently added to the R:BASE Turbo V-8 Report Designer is the option to run a command file (or Action) for
a form before the Report Designer is launched. In the Report Designer, choose "Report" from the Menu bar,
the select "Actions" > "On Before Design...".

This allows you to create any variables that Lookup Variables are based upon to avoid annoying error
messages when the report is opened in the designer. An example of a lookup variable based upon another
variable would be...

1 : TEXT    vCompany = Company IN Customer WHERE CustID = .vCustID

The error message appears because the variable vCustID is not defined. Adding the following SET VAR
command to the "On Before Design..." action will alleviate this error message:

SET VAR vCustID INTEGER

The "On Before Design..." action is located under "Report" > "Actions" on the main Menu Bar.

· Report Variables
Report variables that perform calculations or combine a number of values should be enclosed in parenthesis.
If you are getting an error messages for a variables performing calculations, like the one below,

2 : CURRENCY    vTotal = price * quantity

add parenthesis as follows:

2 : CURRENCY    vTotal = (price * quantity)
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· Report Totals
To be sure your report totals are calculating correctly on all NULL and not NULL records, make sure your
ZERO setting is ON. Check the setting under "Settings" > "Configuration Settings".

· Printer Control Codes
If you used DOS or machine printer control codes in your R:BASE Report variables from previous versions,
they can no longer be stored in the Report Variables. A control code would appear in the variable list with an
expression as follows: <27 40 115 49 83>

If the control code was used to alter the text on the report (i.e. bold, underline, etc.), then just delete the
control code. There are many new features in the Windows interface that replace using control codes for
altering report text objects. The R:BASE Turbo V-8 for Windows version allows you to perform these font
changes must easier.

If you have control codes listed in the report that control hardware for paper feeds or to open a cash
drawer, then write down your exact code and review the "PCC Label" Control in the Report Designer. This
control will allow you to support the same functionality used previously.

· Picture Format
For a report object, you may see [] listed in your report preview.

In R:BASE for DOS and R:BASE for Windows versions prior to 7.x, a "Picture Format" option was available.
The option allowed the justification the value and several formatting options based upon the data type of the
object. To add the justification a [>], or [<] was used to right/left justify.

In the current R:BASE version, this option is now called "Display Format", which still offers several
formatting options for report objects based upon the data type of the object. While the formatting option is
still supported, the justification option is no longer supported in the previous context, within the "Display
Format" settings. To right/left/center justify text of an object, use the "Format" tool bar which supports
many text formatting options.

If you see [] listed in your report preview for a report object, you must right click on the object, select
"Display Format", and remove the [] characters.

· Page Setup
For DOS to Windows conversions, the default page size setting is set to it's largest values in order to make
sure no objects are lost in the conversion process. You must make sure you alter your page settings back to
your desired values in order for your reports to print correctly.

To alter the page size settings, follow the below instructions:

1. Select "File" > "Page Setup..." from the main Menu Bar.
2. Select the "Paper Size" tab
3. For Portrait orientation reports, the Width should be set to "8.5".
4. For Landscape orientation reports, the Height should be set to "8.5".

From this dialog, you can also adjust your report margins from the "Margins" tab.

After making any changes, make sure that all of your report objects are located within the defined page size
settings and margins. Otherwise, R:BASE will display a warning that "Controls beyond the new page width
will be deleted." In this case, select "Cancel" to avoid losing any controls. Then move your controls within
your desired page settings and then make your page size setting changes again.

· Report Preview
The "Report Preview" tab will display a preview of your report as it may appear when you send the report to
the printer or screen. Before selecting the tab, you must make sure that there are no errors listed in your
Report variables, otherwise, you will receive an error message for every error listed multiplied by the
number of records displayed in the Report Preview window.

What you can do to limit the number of rows displayed in the Report Preview window, thus limiting the
number error messages. To do so, alter the Report Default settings for how many rows are displayed when
previewing a report.
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1. Select "Settings" > "Report/Label Designer" > "Default Settings..." from the main Menu Bar.
2. Alter the value for "Row Count for Preview:" to a smaller value other than 100; perhaps to 10.

· Legacy Objects
Any lines created in R:BASE for DOS will be removed. If you created lines in a DOS version of R:BASE by
using text (such as dashes or underscores), these objects will be treated as text objects. These may show
up as strings of strange letters such as "ä". You will want delete these objects and replace them with actual
line objects within the Report Designer.

To learn more about the Report Designer and controls, please review Report Designer help file by pressing the
[Shift]+[F1] hot keys.

And, if you have not done so already, complete the R:BASE Tutorial in its entirety.

From the Main Menu, choose "Help" > "R:BASE Tutorial". This tutorial covers step-by-step instructions on
building a complete database and application from scratch providing the R:BASE relational logic as it adhere's
to Dr. Codd's relational model. This is where one would initially learn how to quickly adapt to the R:BASE
interface!

2.2.3.1.3  Converting Labels

You should now be looking at the R:BASE window with the Database Explorer displayed. To confirm, you will
see the main R:BASE caption read the "R:BASE Turbo V-8", then your database name listed in square
brackets, then "R:BASE Database Explorer" listed in square brackets.

· If you do not see your database listed in brackets, then connect to it now by selecting "Database" >
"Connect to Database..." from the main Menu Bar. You will be prompted to locate your database files
where they are stored on your computer. Once connected to your database, you will see the database
name listed in the R:BASE Turbo V-8 program caption in brackets.

· If you do not see "R:BASE Database Explorer" listed in square brackets, then select the "Database
Explorer" button on the main Tool Bar. It is the first button on the left and the hint displayed will read
"Show Database Explorer".

At the Database Explorer window, you will see the "Group Bar" listed on the left side of the window containing
various menu options of R:BASE database modules (i.e. Tables, Views, Forms, etc.)

1. Click on the "Labels" menu option of the Group Bar (figure 1) and select the "Convert" sub menu option
(figure 2).
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(figure 1)

(figure 2)

Upon pressing this button, you will see that a dialog containing a list of the available labels is displayed
(figure 3).

(figure 3)

2. Select the label that you want to convert, and press the "OK" button.

The Label Designer will convert and launch the report in the designer.

At this point, you can now make changes to your label! However, since many of the issues and suggestions
refer to specific object names and require basic understanding of the Label Designer, it is recommended, that
you perform the conversions of the remaining modules (i.e. forms, reports), and then complete the R:BASE
Tutorial before continuing.

From the Main Menu, choose "Help" > "R:BASE Tutorial". This tutorial covers step-by-step instructions on
building a complete database and application from scratch providing the R:BASE relational logic as it adhere's
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to Dr. Codd's relational model. This is where one would initially learn how to quickly adapt to the R:BASE
interface!

2.2.3.1.3.1  Issues and Suggestions

From this point in the conversion process, you can now make the necessary improvements on your existing
label design, and consider the listed suggestions.

NOTE: From inside the Label Designer, you can launch the Label Designer help file by pressing the
[Shift]+[F1] hot keys.

· Sub-Totals and Totals
To calculate sub-totals and totals of table columns, Aggregate Variables have always been used to perform
this job. Now, the R:BASE Turbo V-8 for Windows Label Designer has a built-in object called DBCalc, which
performs these same functions on table columns without creating the extra overhead of variables. You can
replace your Variable Label objects with DBCalc objects in instances where the Variables Object results will
not be used further down in the label.

· #DATE, #TIME, #PAGE, Document, and Page Information
R:BASE Turbo V-8 for Windows Label Designer now has an object called System Variable, which allows you
to place the current DATE, TIME, Document Name, Print DATE and TIME, or one of five Page Numbering
options. You should delete any Variable Label objects whose expression value consists of a System Variable
(#DATE, #TIME) and replace that object with a System Variable object. If you have any Variable Label
objects whose expression value consists of the #PAGE System Variable you must delete the variable object
and replace that object with a System Variable object.

· Lookup Variable Tip
Recently added to the R:BASE Turbo V-8 Label Designer is the option to run a command file (or Action) for a
form before the Label Designer is launched. In the Label Designer, choose "Label" from the Menu bar, the
select "Actions" > "On Before Design...".

This allows you to create any variables that Lookup Variables are based upon to avoid annoying error
messages when the label is opened in the designer. An example of a lookup variable based upon another
variable would be...

1 : TEXT    vCompany = Company IN Customer WHERE CustID = .vCustID

The error message appears because the variable vCustID is not defined. Adding the following SET VAR
command to the "On Before Design..." action will alleviate this error message:

SET VAR vCustID INTEGER

The "On Before Design..." action is located under "Label" > "Actions" on the main Menu Bar.

· Label Variables
Label variables that perform calculations or combine a number of values should be enclosed in parenthesis.
If you are getting an error messages for a variables performing calculations, like the one below,

2 : CURRENCY    vTotal = price * quantity

add parenthesis as follows:

2 : CURRENCY    vTotal = (price * quantity)

· Label Totals
To be sure your label totals are calculating correctly on all NULL and not NULL records, make sure your
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ZERO setting is ON. Check the setting under "Settings" > "Configuration Settings".

· Printer Control Codes
If you used DOS or machine printer control codes in your R:BASE Label variables from previous versions,
they can no longer be stored in the Label Variables. A control code would appear in the variable list with an
expression as follows: <27 40 115 49 83>

If the control code was used to alter the text on the label (i.e. bold, underline, etc.), then just delete the
control code. There are many new features in the Windows interface that replace using control codes for
altering label text objects. The R:BASE Turbo V-8 for Windows version allows you to perform these font
changes must easier.

If you have control codes listed in the label that control hardware for paper feeds or to open a cash drawer,
then write down your exact code and review the "PCC Label" Control in the Label Designer. This control will
allow you to support the same functionality used previously.

· Picture Format
For a label object, you may see [] listed in your label preview.

In R:BASE for DOS and R:BASE for Windows versions prior to 7.x, a "Picture Format" option was available.
The option allowed the justification the value and several formatting options based upon the data type of the
object. To add the justification a [>], or [<] was used to right/left justify.

In the current R:BASE version, this option is now called "Display Format", which still offers several
formatting options for label objects based upon the data type of the object. While the formatting option is
still supported, the justification option is no longer supported in the previous context, within the "Display
Format" settings. To right/left/center justify text of an object, use the "Format" tool bar which supports
many text formatting options.

If you see [] listed in your label preview for a label object, you must right click on the object, select "Display
Format", and remove the [] characters.

· Page Setup
For DOS to Windows conversions, the default page size setting is set to it's largest values in order to make
sure no objects are lost in the conversion process. You must make sure you alter your page settings back to
your desired values in order for your labels to print correctly.

To alter the page size settings, follow the below instructions:

1. Select "File" > "Page Setup..." from the main Menu Bar.
2. Select the "Paper Size" tab
3. For Portrait orientation labels, the Width should be set to "8.5".
4. For Landscape orientation labels, the Height should be set to "8.5".

From this dialog, you can also adjust your label margins from the "Margins" tab.

After making any changes, make sure that all of your label objects are located within the defined page size
settings and margins. Otherwise, R:BASE will display a warning that "Controls beyond the new page width
will be deleted." In this case, select "Cancel" to avoid losing any controls. Then move your controls within
your desired page settings and then make your page size setting changes again.

· Label Preview
The "Label Preview" tab will display a preview of your label as it may appear when you send the label to the
printer or screen. Before selecting the tab, you must make sure that there are no errors listed in your Label
variables, otherwise, you will receive an error message for every error listed multiplied by the number of
records displayed in the Label Preview window.

What you can do to limit the number of rows displayed in the Label Preview window, thus limiting the
number error messages. To do so, alter the Label Default settings for how many rows are displayed when
previewing a label.

1. Select "Settings" > "Report/Label Designer" > "Default Settings..." from the main Menu Bar.
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2. Alter the value for "Row Count for Preview:" to a smaller value other than 100; perhaps to 10.

· Legacy Objects
Any lines created in R:BASE for DOS will be removed. If you created lines in a DOS version of R:BASE by
using text (such as dashes or underscores), these objects will be treated as text objects. These may show
up as strings of strange letters such as "ä". You will want delete these objects and replace them with actual
line objects within the Label Designer.

To learn more about the Label Designer and controls, please review Label Designer help file by pressing the
[Shift]+[F1] hot keys.

And, if you have not done so already, complete the R:BASE Tutorial in its entirety.

From the Main Menu, choose "Help" > "R:BASE Tutorial". This tutorial covers step-by-step instructions on
building a complete database and application from scratch providing the R:BASE relational logic as it adhere's
to Dr. Codd's relational model. This is where one would initially learn how to quickly adapt to the R:BASE
interface!

2.2.3.2 R:BASE 7.0 and Higher Forms, Reports, & Labels

After running the conversion steps to create your R:BASE Turbo V-8 database files, your Forms, Reports, and
Labels will automatically populate the Forms, Reports, and Labels menus of the R:BASE Database Explorer. The
items will run in R:BASE Turbo V-8 with little or no changes.

It is recommended that you review each item to insure the conversion was 100% successful.
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3 Converting Applications

As R:BASE can be customized for any type of business model or company schema, there have always been
several ways that developers and users could create an application. Actually, if you think of what an application
consists of, you're really looking at a stored series of commands in what are called a command files, which are
then combined with other command files to form applications.

R:BASE provides all of the tools you need to produce command files and applications, it is just up to you to
decide which method serves your needs best.

3.1 R:BASE 6.5++ and Lower Applications

3.1.1 Application Express Users

If you are converting an application that was designed using the Application Express module from versions
prior to R:BASE 7.x, the actual application file consisting of the R:BASE command language (.APP) can be used
in R:BASE Turbo V-8. In addition to the .APP file, there will be an .APX and either .API or .APW files. You will
only need the .APP file.

The source code command syntax within the APP file contains the menus and menu actions of your custom
application. The APP file is likely located with your database files. So, when you connect to your database using
R:BASE Turbo V-8, you will see the APP file listed under the "Command Files" menu within the Database
Explorer's Group Bar. The files will not be listed under the "Applications" menu as the R:BASE Turbo V-8
Application Designer will not open prior Application Express projects for editing.

In order to use the .APP file contents in R:BASE Turbo V-8, you will need to review and update the command
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syntax used in the file. Based on the R:BASE version you are upgrading from, there are additional steps
needed to upgrade your application code. The older your application is, then the more steps will be needed.
And, if you are upgrading from a DOS version, there are additional changes required as well.

In R:BASE Turbo V-8, you have several different ways to run the menus contained within this file. Please
review the several Application Formats available to you.

3.1.2 Command Files

The application may be one large .APP file or several smaller files; usually with the .CMD file extension. The
standard command file extension was CMD in the DOS days. Now in R:BASE Turbo V-8 for Windows, the new
standard is .RMD as more file servers and mail servers flag the .CMD file extension as a possible virus. If you
are using a custom file extension, you can add the extension to the "File Mask:" field under the "Command
Files" option and they will then appear in this window.

In order to use your command files in R:BASE Turbo V-8, you will need to review and update the command
syntax used in the files. Based on the R:BASE version you are upgrading from, there are additional steps
needed to upgrade your command syntax. The older your command files are, then the more steps will be
needed. And, if you are upgrading from a DOS version, there are additional changes required as well.

In R:BASE Turbo V-8, you have several different ways to run the menus contained within this file. Please
review the several Application Formats available to you.

3.1.3 New Application Formats

When building R:BASE databases and applications, R:BASE users have several options as to how they want to
store their "application".

1. Forms - an application can be completely Form driven by storing all of the code in form EEPs.

2. Application Builder - using the Application Builder interface, an application can be stored in a .RBA file,
separate from the database files. This offers additional security over using just command files.

3. Command Files - using only code (i.e. CHOOSE, DIALOG, PAUSE, etc), an application can be entirely
written in one or many RMD, APP, CMD, and DAT files.

4. External Form Files - an application can be driven using External Forms, by storing all of the code in
form EEPs. Like an R:BASE Application file (.RBA), External Form Files are stored outside of the database.

5. All, or some, of the above - an application can consist of all of a few of the above methods to store
R:BASE menu and command files.

3.1.4 Updating the Command Syntax

Based on the R:BASE version you are upgrading from, there are additional steps needed to upgrade your
application code. The older your application is, then the more steps will be needed.

You may encounter reserved words (PROJECT, TIME), obsolete commands (SET POINTER), and/or commands
whose syntax has been enhanced for your benefit (PRINT, SELECT, CHOOSE). The time inveested to perform
these changes depends on the size of your command files.

3.1.4.1 Table and Column Name Changes

During the initial Preparation stages of the conversion process you were instructed to review change your table
and column names which match any invalid names and reserved words, and to record these changes on paper.

If you made any table and/or column name changes, the first step in your command syntax updates is to
make these necessary name changes in the application/command files.

One suggestion for task this task is to use the R:BASE built-in "Find Files" utility. To launch this command file
utility, choose "Utilities" > "Find Files" from the main Menu bar. This interface will allow to to search your
command files for obsolete commands and other words, so you are not forced to manually search the
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individual files.

Keep in mind that whether you are using the R:BASE Editor or another text editor, to make these command
syntax updates it is wise to take advantage of all of the utilities available in the text editor. In this case where
you are replacing keywords, be sure to use any built-in word Search and Replace utilities to make this task
easier.

You can review the list of Reserved Words at any time.

3.1.4.2 Obsolete Commands

The following table contains a list of commands that are considered to be obsolete. Most of these commands
have been made obsolete by their SQL Compliant equivalent, and there is no guarantee that these commands
will be supported in future versions of R:BASE. Any code which relies on any of these commands should be
considered dangerous as their use may have unintended and unpredictable results.

While most items have a direct replacement there are some items that are listed as having no direct
replacement. However it may be possible to replace those commands with other commands that emulate that
functionality. For more information on the "Replacement" commands, refer to the R:BASE Help "Command
Index", or press [F1] from any location in R:BASE.

One suggestion for task this task is to use the R:BASE built-in "Find Files" utility. To launch this command file
utility, choose "Utilities" > "Find Files" from the main Menu bar. This interface will allow you to search your
command files for obsolete commands and other words, so you are not forced to manually search the
individual files.
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Obsolete Command Replacement Notes

#FORM_COLUMNNAME RBTI_FORM_COLNAME See also RBTI
System Variables

#FORM_FORMNAME RBTI_FORM_FORMNAME See also RBTI
System Variables

#FORM_TABLENAME RBTI_FORM_TBLNAME See also RBTI
System Variables

AVE() LAVG

BUILD KEY CREATE INDEX

CHANGE UPDATE

CHANGE COLUMN ALTER TABLE

CLOSE DISCONNECT

COLUMNS CREATE TABLE

(CVAL('FORM_ALIAS') RBTI_FORM_ALIAS See also RBTI
System Variables

(CVAL('FORM_CAPTION') GETPROPERTY RBASE_FORM CAPTION vCaption

(CVAL('FORM_DATA') RBTI_FORM_COLVALUE See also RBTI
System Variables

(CVAL('FORM_DATA_TYPE') RBTI_FORM_DATATYPE See also RBTI
System Variables

(CVAL('FORM_FIELD_NAME') RBTI_FORM_COLNAME See also RBTI
System Variables

(CVAL('FORM_NAME') RBTI_FORM_FORMNAME See also RBTI
System Variables

(CVAL('FORM_TABLE') RBTI_FORM_TABLENAME See also RBTI
System Variables

DEFINE CREATE SCHEMA

DELETE KEY DROP INDEX

DELETE FROM #n DELETE FROM TableName
WHERE CURRENT OF CURSOR

See also DECLARE
CURSOR



R:BASE Turbo V-8 for Windows Database Conversion Guide35

Copyright © 1982-2008 R:BASE Technologies, Inc.

DISPLAY EDIT USING Used with Variable
Forms.

DRAW NONE Used with Variable
Forms. No direct

replacement.

ECHO SET ECHO ON

EDIT VAR ... NONE Used with Variable
Forms. No direct

replacement.

ENTER VAR ... NONE Used with Variable
Forms. No direct

replacement.

ESC [ESC] Used in IF and
WHERE clauses to
compare to the Esc

key.

Value1 EQ Value2 Value1 = Value2 Value1 equals
Value2

EXISTS IS NOT NULL

EXPAND ALTER TABLE

EXPRESS RBAPP

FAILS IS NULL

FILLIN DIALOG In windows
consider using

DIALOG, ENTER or
EDIT.

Value1 GE Value2 Value1 >= Value2 Value1 greater than
or equal to

Value2.

Value1 GT Value2 Value1 > Value2 Value1 greater than
Value2.

IN #n WHERE CURRENT OF CURSOR Used with UPDATE
and SET VAR
commands.

Value1 LE Value2 Value1 <= Value2 Value1 less than or
equal to Value2.

Value1 LT Value2 Value1 < Value2 Value1 less than or
equal to
Value2.
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MAX() LMAX()

MICRORIM_RETURN STP_RETURN

MICRORIM_WALLPAPER NONE This variable was
only used with

Forms and Reports
created for R:WEB.

MIN() LMIN()

Value1 NE Value2 Value1 <> Value2 Value1 does not
equal Value2.

NEXT FETCH See also DECLARE
CURSOR

NOECHO SET ECHO OFF

OPEN CONNECT

OWNER CREATE SCHEMA

PASSWORDS GRANT

PLAYBACK NONE No Replacement.

POPUP/PULLDOWN Menus NONE Use #LIST option of
CHOOSE command.

Use LISTOF
command option to
create list of items.

PROMPTS Now DOS Only.

REDEFINE ALTER TABLE

REMOVE DROP

RESET NONE No Replacement.

#RETURN NONE Used with Variable
Forms. No Direct

Replacement.

SCREEN RESTORE RECALC VARIABLES Now DOS Only.

SELECT FROM #n SELECT FROM TableName See also DECLARE
CURSOR WHERE

CURRENT OF
CURSOR



R:BASE Turbo V-8 for Windows Database Conversion Guide37

Copyright © 1982-2008 R:BASE Technologies, Inc.

SET CGA NONE No Replacement.

SET EDITOR NONE No Replacement
due to enhanced
RBEDIT module.

SET EXTENDED NONE R:BASE always
operates in

Extended Mode
now.

SET INTENSITY NONE Use "Selected Row"
color option in

Scrolling Region
Properties.

SET OLDLINE NONE Use the Page Style
option in Reports.

SET POINTER DECLARE CURSOR

SET RBGSIZE No replacement
necessary due to

imbedded 7.x
properties.

Command is
ignored.

SET USERAPP NONE No replacement.

SORTED BY ORDER BY

USER CONNECT IDENTIFIED BY ...

VIEW CREATE VIEW

WRITE In Windows
consider using

DIALOG,
PAUSE, ENTER or

EDIT.

ZIP RBEDIT RBEDIT RBEDIT is no longer
a seperate
executable.

ZIP RBSYNC RBSYNC RBSYNC is no
longer a seperate

executable.

3.1.4.3 DOS to Windows Conversion

When converting from DOS to Windows, there are command syntax changes that may or may not require your
attention.

Instances where you will positively update the command syntax are any locations where DOS message
commands (WRITE) or information prompts (FILLIN) which will need replaced by their Windows counterpart
(PAUSE and DIALOG).

These commands send simple messages or prompts for data entry to the end user. Your time involved in this
step depends on how much user interaction is in the code.

To assist you with these replacements, R:BASE Turbo V-8 for Windows includes several syntax builders for the
DIALOG and PAUSE commands. They can be accessed from the Menu Bar under "Utilities" > "Plugins".

For WRITE, you may have this;
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WRITE 'THE PROCESS IS COIMPLETE!' AT 10 05

and will replace it with this:

PAUSE 2 USING 'THE PROCESS IS COIMPLETE!' CAPTION ' ' ICON INFO

For FILLIN, you may have this;

FILLIN vdte USING 'ENTER DEADLINE DATE: ' AT 12 10

and will replace it with this:

DIALOG 'ENTER DEADLINE DATE:' vdte venke 1 CAPTION 'Question'
ICON QUESTION

3.1.4.4 Enhanced Commands

There will be commands whose syntax has been enhanced for your benefit. Most of these commands will not
require mandatory changes other than for an enhanced display (CHOOSE, DIALOG, PAUSE, PRINT), but the
PRINT command is an example of a command that has been enhanced 20 times over, and will require you to
alter your syntax.

You may have this:

OUT PRINTER
PRINT bulletin SORTED BY poscl
OUT screen

and will replace it with this:

PRINT bulletin ORDER BY poscl ASC OPTION PRINTER

or even this:

PRINT bulletin ORDER BY poscl ASC OPTION PRINTER +
|SHOW_CANCEL_DIALOG OFF |TRAY 2 |COLLATION ON +
|COPIES 2 |ORIENTATION LANDSCAPE |PRINTER_NAME HPLaser1345

3.1.5 Using the R:BASE Editor

You may be thinking that this is too much. But, there are two important tools included with R:BASE Turbo V-8
that will make your command syntax changes more pleasant that you think.

The new R:BASE Editor & R:Style!

The R:BASE Editor is an editor specifically designed for creation and editing of R:BASE program and application
files, command files, recorded scripts, and text files. It offers these special R:BASE features:
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· You can specify settings such as the font, tab stops, and text   wrapping. You can also search and replace
text, and print files.

· Any number of program files can be open simultaneously.
· Command files are shown with syntax highlighting with the option of displaying each syntax element in a

different color text.
· Safe tabs -- the Tab key inserts spaces.
· Block commands include block indent, block outdent, block comment out, and block comment in.
· Seamless integration with the R:Style, R:BASE code styler and checker.
· And more...

What is R:Style?

R:Style provides structural error checking, and spelling assistance to help debug your code prior to running it.
R:Style will tell you where in the file to look, and what error to look for! R:Style is not a full syntax checker,
but it is an excellent structure checker, with some syntax checking thrown in as a bonus.

R:Style will find:

· Mis-terminated lines (= instead of +)
· Illegal or ambiguous commands
· Missing, unmatched, or incorrect quotes
· Unmatched parenthesis
· Missing RETURNs & ENDs, adds them
· Missing or out of place structures, IF, THEN, ELSE, ENDIF, SWITCH, ENDSW, WHILE, THEN, ENDWHILE,

BREAK
· Duplicate block names in APP files
· Illegal use of command words in code or block names
· Ill advised RETURN from within WHILE or SWITCH
· Illegal dotted variables
· Support for finding misspelled or illegal words

· And more...

3.2 R:BASE 7.0 and Higher Applications

Any .RBA Application files, Form-Driven Applications, External Form Files, or command files running in R:BASE
7.0 and higher will run in R:BASE Turbo V-8 with little or no changes.

It is recommended that you review your application menus and actions to insure the system is 100%
operational.
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4 Feedback

Suggestions and Enhancement Requests:

From time to time, everyone comes up with an idea for something they'd like their software to do differently.
This is true of all applications, no less R:BASE.

If you come across an idea that you think might make a nice enhancement to R:BASE, your input is always
welcome.

Please submit your suggestion and/or enhancement request at our online R:BASE Developers' Corner Crew
(R:DCC) homepage at: http://www.rbase.com/RBG7RDCC.  Describe what you think might make a nice
enhancement.

Unless additional information is needed, you will not receive a direct response. You can periodically check the
status of your submitted enhancement request accordingly.

Reporting Bugs:

If you experience something you think might be a bug in R:BASE, please report it at our online R:BASE
Developers' Corner Crew (R:DCC) homepage at: http://www.rbase.com/RBG7RDCC.

You will need to describe:

· What you did
· What happened
· What version and build of R:BASE you have
· Any error messages R:BASE gave
· What kind of computer you have
· Which operating system you're using
· Anything else you think might be relevant

Unless additional information is needed, you will not receive a direct response. You can periodically check the
status of your submitted bug accordingly.

If you would like to send the sample as an attachment in reference to submitted bug on RBG76 RDCC, please
send an e-mail to rbg8rdcc@rbase.com.

http://www.rbase.com/RBG7RDCC
http://www.rbase.com/RBG7RDCC
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