
R:BASE Technologies, Inc.

DOS to Windows 
Database Conversion 

Guide

R:BASE eXtreme 9.5



R:BASE eXtreme 9.5

DOS to Windows Database Conversion Guide

by R:BASE Technologies, Inc.

Welcome to R:BASE eXtreme 9.5!

R:BASE eXtreme 9.5 for Windows is a new relational database
development environment that has been amplified to provide the
latest menu-driven features to database professionals. With the
R:BASE engine established as the foundation of stability, the
program interface and designers have been enhanced to fully
exhibit the highest quality of development usability.

The "eXtreme" in the product's name signifies the cutting-edge
development interface incorporated into the R:BASE program
making database and application development more productive.
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1 Preparation

When preparing to convert a legacy database and use those files in R:BASE eXtreme, it is important
that you follow the proper steps to convert that database. Please review the following steps and
recommendations to ensure you convert your legacy database(s) successfully.

1.1 Make a Database Backup

Before you begin, make a backup copy of your database. You should place the database on a storage
medium that is different than the one which your original files are already stored upon. For example, if
you are using a hard disk to store the data, you can back up your database to an external hard drive, a
flash drive, a tape drive, or a CD-ROM. With these storage options, you can also copy the backup files
back to your hard drive. 

If users are still entering data into the live database, while the conversion is taking place, use a different
database copy than the one in use. When the conversion is complete, the live data being added to can
always be loaded into the converted database at a later time. Make sure no users are connected to the
database when the copy is made.

During the conversion process, it is also recommended to make periodic backups. This will prevent you
from starting from the beginning in case any problems occur.

1.2 Review Table and Column Names

You must review all table and column names to be sure that no invalid names are defined and no
reserved words are used. 

In the current version, a 1-18 character alpha-numeric name must be specified for a column. Spaces are
NOT permitted. Valid names must start with an alpha character and can include the following symbols: 

Letters (A-Z)
Numbers (0-9)
_ (underscore)
# (pound sign) *
$ (dollar sign) *
% (percent sign) *

*Note: For ODBC compliance, it is NOT recommended to use the #, $, or % even though R:BASE
permits it.

Review your table and column names that may begin with a number. Check for any characters that are
not supported like a question mark "?" or a greater than character ">". 

Also review your table and column names to verify that no reserved words are used. These words,
commands, keywords, and other names are to be used exclusively by the R:BASE database. Names
used by System Tables, System Views and System Columns are also reserved words. As a rule, all
words beginning with "SYS" are reserved.

Do not use reserved words or any shorter forms of them as names for columns, tables, or views. As a
rule, if the word is a reserved word, R:BASE will flag it. R:BASE will not allow you to use a reserved word
as a column or table name, but this MAY NOT always be the case. For example in the table designer,
R:BASE may not warn you about REF, short for REFERENCES, but REF will not be allowed in a
command file. If a particular column or table is giving you problems, please check out the list below and
consider all shortened versions of the words listed here.

The following is a list of all known reserved words, commands, keywords, and other names that are in
effect when ANSI is set on, which is the default setting. 

100_PERCENT
128BIT

ATTA
ATTACH
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40BIT
ABO
ABORT
ABS
ABSO
ABSOLUTE
ACC
ACCESS
ACOS
ACTION
ACTIVE
ACTIVECOLOR
ACTIVEOUTLINECOLOR
ACTIVEPAGEINDEX
ADA
ADD
ADD19
ADDDAY
ADDFRC
ADDHR
ADDMIN
ADDMON
ADDSEC
ADDYR
AINT
ALIAS
ALIGN
ALIGNMENT
ALIGNTABS
ALL
ALLOWGRAYED
ALLOWKEYEDIT
ALLOWOPEN
ALPHABLEND
ALPHABLENDVALUE
ALT
ALTER
anchors
AND
ANGLE
ANIMATE
ANINT
ANS
ANSI
ANY
ANY_COLOR
APP
APPEND
APPEND_DUPLICATE
APPLICATION
APPLYSETTINGS
ARR
ARRANGE
AS
ASC
ASCII
ASIN
ASS
ASSIGN
AT
ATAN
ATAN2
ATT

ATTACHMENTS
AUTH
AUTHOR
AUTHORIZATION
AUTHORIZE
AUTO_MAXIMIZE_WINDOW
AUTOC
AUTOCHK
AUTOCOM
AUTOCOMMIT
AUTOCON
AUTOCONVERT
AUTODROP
AUTODROPDOWN
AUTOEXPAND
AUTOF
AUTOFIX
AUTON
AUTONUM
AUTONUMBER
AUTORECOVER
AUTOROWVER
AUTOSCROLL
AUTOSELECT
AUTOSIZE
AUTOSK
AUTOSKIP
AUTOSNAP
AUTOSY
AUTOSYNC
AUTOUPGRADE
AVE
AVERAGE
AVG
BAC
BACK_COLOR
BACKCOLOR
BACKGRND
BACKGROUND_COLOR
BACKGROUND_FILE
BACKGROUND_TYPE
BACKGROUNDCOLOR
BackgroundColorField
BACKUP
BARCOLOR
BCC_LIST
BEE
BEEP
BEF
BEFORE
BEGIN
BEGINS
BEL
BELL
BET
BETWEEN
BEVELED
BEVELHIGHLIGHTCOLOR
BEVELSHADOWCOLOR
BEVELWIDTH
BIN
BINARY
BIT

BITN
BITNOTE

BUTTONS_SHOW_GLYPH
BUTTONWIDTH
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BLA
BLACK
BLANK
BLANKVALUE
BLI
BLINDS_HOR
BLINDS_VERT
BLINK
BLINKCOLOR
BLINKING
BLINKINTERVALOFF
BLINKINTERVALON
BLU
BLUE
BODY
BORDERCOLOR
BORDERHIGHLIGHT
BORDERSHADOW
BORDERWIDTH
BOT
BOTH
BOX_INWARD
BOX_OUTWARD
BRE
BREAK
BRN
BRND
BRO
BROWN
BROWS
BROWSE
BRUSH_COLOR
BTN100PERCENT_VISIBLE
BTNCANCEL_VISIBLE
BTNFIRST_VISIBLE
BTNLAST_VISIBLE
BTNNEXT_VISIBLE
BTNPAGEWIDTH_VISIBLE
BTNPRINT_VISIBLE
BTNPRIOR_VISIBLE
BTNWHOLEPAGE_VISIBLE
BTNZOOMPERCENATAGE_VISIBLE
BUI
BUILD
BUTTON
BUTTON_CANCEL_CAPTION
BUTTON_CANCEL_WIDTH
BUTTON_COLOR
BUTTON_FONT_COLOR
BUTTON_NO_CAPTION
BUTTON_NO_COLOR
BUTTON_NO_FONT_COLOR
BUTTON_NO_FONT_SIZE
BUTTON_OK_CAPTION
BUTTON_OK_WIDTH
BUTTON_YES_CAPTION
BUTTON_YES_COLOR
BUTTON_YES_FONT_COLOR
BUTTON_YES_FONT_SIZE
ButtonEnter
BUTTONS_BACK_COLOR
BUTTONS_FONT_COLOR
BUTTONS_FONT_SIZE

BY
C
CALL
CANCEL
CANCELHINT
CANCLOSE
CAP
CAPTION
CAPTIONCOLOR
CAPTIONCOLORDEFAULT
CAPTIONHEIGHT
CAPTIONHOTCOLOR
CAPTIONX
CAPTIONY
CAS
CASC
CASCADE
CASE
CASEP
CC_LIST
CD
CDECL
CELL_ATTR
CENT
CENTER
CENTER_WINDOW
CENTU
CENTURY
CGA
CHA
CHANGE
CHANGEDELAY
CHAR
CHARA
CHARACTER
CHARACTERS
CHARCASE
CHART_TITLE
CHDI
CHDIR
CHDR
CHDRV
CHE
CHECK
CHECKED
checkindex
CHECKRANGE
CHK
CHKB
CHKBOX
CHKCOMPID
CHKCUR
CHKDSK
CHKF
CHKFILE
CHKK
CHKKEY
CHKS
CHKSORT
CHKVAR
CHO
CHOOSE
CLE

CLEAR
CLEARFILTER

CREATEOBJECT
CREATOR
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CLEARIMAGE
ClickableTitle
CLIENTHEIGHT
CLIENTWIDTH
CLIPBOARD
CLKARROWCOLOR
CLKFACECOLOR
CLOSE
CLOSEW
CLOSEWINDOW
CLS
COBOL
COD
CODELOCK
COL
COLCOUNT
COLL
COLLATE
COLLATEC
COLLATION
COLOR
COLORADJUSTMENT
COLORDEFAULT
COLU
COLUMN
COLUMNS
COMMAND
COMME
COMMENT
COMMI
COMMIT
COMP
COMPATIB
COMPATIBILITY
COMPID
COMPRESSION
COMPRESSION_LEVEL
COMPRESSION_METHOD
COMPRESSION_TYPE
COMPUTE
COMPUTED
CONFIRMDELETE
CONFIRMTEXT
CONN
CONNECT
CONS
CONSTRAINT
CONSTRAINTS
CONT
CONTAINS
CONTI
CONTINUE
CONV
CONVERT
COP
COPIES
COPY
COPYTOCLIPBOARD
COS
COSH
COUNT
CRE
CREATE

CRO
CROSSTAB
CSSFILE
CSV
CTR
CTXT
CURR
CURRENCY
CURRENT
CurrentColumnName
CURRNUMALLOC
CURS
CURSOR
CURSORCOL
CURSORROW
CURSORS
CUTCORNERSIZE
CUTTOCLIPBOARD
CVAL
CYA
CYAN
DAT
DATA
DATAB
DATABASES
DATE
DATET
DATETIME
DBSIZE
DEB
DEBUG
DEC
DECIMAL
DECIMALS
DECL
DECLA
DECLAR
DECLARE
DEFA
DEFAULT
DEFAULT_COLOR
DEFAULT_FONT_BOLD
DEFAULT_FONT_COLOR
DEFAULT_FONT_ITALIC
DEFAULT_FONT_NAME
DEFAULT_FONT_SIZE
DEFAULT_FONT_STRIKEOUT
DEFAULT_FONT_UNDERLINE
DEFAULTDIRECTORY
DEFAULTVALUE
DEFF
DEFI
DEFINE
DEL
DELETE
DELETEHINT
DELETEOBJECT
DELIMIT
DELIMITER
DELR
DELROW
DES
DESC

DET
DETA

EEPNUM
ELS
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DETACH
DEXTRACT
DIA
DIAL
DIALOG
DIALOG_EDIT_HINT
DIFHOUR
DIFMINUTE
DIM
DIR
DIS
DISABLE_ADD_NEW_ROWS
DISABLE_COPYING
DISABLE_DELETE_ROWS
DISABLE_RIGHT_CLICK
DISABLECLOSEACTION
DisableDoubleClick
DISC
DISCONNECT
DISKSPACE
DISP
DISPLAY
DISPLAY_DOC_TITLE
DISSOLVE
DISTINCT
DIVIDERCOLOR
DIVIDERVISIBLE
DLCALL
DLFREE
DLLOAD
DNW
DOC_LIST_FILE
DOCUMENT_NAME
DontShowDeleteDialog
DONTSHOWSAVEDIALOG
DOU
DOUBLE
DOWN
DRA
DRAGDROPENABLED
DRAW
DRAWGRADIENT
DRO
DROP
DROPDOWNCOUNT
DROPDOWNWIDTH
DroppedItemIndex
DUP
DUPLEX
DUPLICATE
DUPLICATES
DUPROW
DURATION
DWE
DWR
DWRD
ECH
ECHO
EDI
EDIT
EDITHINT
EDITOR
EEP

ELSE
EMAIL
EMAIL_ATTACHMENTS
EMAIL_AUTHENTICATION
EMAIL_BCC_LIST
EMAIL_BODY
EMAIL_CC_LIST
EMAIL_DATE
EMAIL_DELETE_AFTER_SEND
EMAIL_FROM_ADDRESS
EMAIL_FROM_NAME
EMAIL_HOST
EMAIL_PASSWORD
EMAIL_PORT
EMAIL_REPLY
EMAIL_SHOW_DIALOG
EMAIL_SUBJECT
EMAIL_TO_LIST
EMAIL_USERID
EMBED_USED_FONTS
ENABLE_ADD_NEW_ROWS
ENABLE_COPYING
ENABLE_DELETE_ROWS
ENABLE_MODIFYING
ENABLE_PRINTING
ENABLED
ENCRYPT
ENCRYPT_FILE
ENCRYPTION_ALLOW_ACCESSIBILITY
ENCRYPTION_ALLOW_ANNOTATION
ENCRYPTION_ALLOW_ASSEMBLY
ENCRYPTION_ALLOW_COPY
ENCRYPTION_ALLOW_FORM_FILL
ENCRYPTION_ALLOW_MODIFY
ENCRYPTION_ALLOW_PRINT
ENCRYPTION_ENABLE
ENCRYPTION_HIRES_PRINT
ENCRYPTION_LEVEL
ENCRYPTION_OWNER_PASSWORD
ENCRYPTION_USER_PASSWORD
END
ENDC
ENDI
ENDIF
ENDSW
ENDW
ENDWHILE
ENT
ENTER
ENVVAL
EOF
EOFCHAR
EQN
EQNULL
ERA
ERASE
ERR
ERROR
ESC
ESCAPE
EvenColor
EVERYTHING
EXC

EXCEPT
EXCLUSIVEMODE

FOLD
FONT
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EXE
EXECUTE
EXI
EXISTS
EXIT
EXITF
EXITFORM
EXP
EXPA
EXPAND
EXPL
EXPLODE
EXPO
EXPORT
EXPRESS
EXTENDED
EXTRACT
FAI
FAILS
FALSE
FASTEST
FASTF
FASTFK
FASTL
FASTLOCK
FEE
FEEDBACK
FET
FETCH
FIL
FILE
FILENAME
FILES
FILL
FILLI
FILLIN
FILLLASTCOLUMN
FIN
FINDFILE
FINT_UNDERLINE
FIR
FIRST
FIRSTCHAR
FIRSTHINT
FIT_WINDOW
FIXED
FIXEDCOLOR
FIXEDCOLS
FKE
FKEYS
FLAT
FLATBUTTONS
FLATCOLOR
FLATCOLORADJUSTMENT
FLATE
FLATSCROLLBARS
FLDNAME
FLO
FLOAT
FLU
FLUSH
FLYBYCOLOR
FLYBYENABLED

FONT_BOLD
FONT_COLOR
FONT_ENCODING
FONT_HEIGHT
FONT_ITALIC
FONT_NAME
FONT_SIZE
FONT_STRIKEOUT
FONT_UNDERLINE
FOO
FOOTING
FOR
FOREG
FOREGRND
ForegroundColorField
FOREI
FOREIGN
FORM
FORM_CONTROL_TYPE
FORM_DIRTY_FLAG
FORMAT
FORMATT
FORMATTED
FORMI
FORMING
FORMS
FORTRAN
FOU
FOUND
FRAMECOLOR
FRAMEFLAT
FRAMEVISIBLE
FRO
FROM
FROM_ADDRESS
FROM_NAME
FUL
FULL
FULL_OPEN
FULL_SCREEN
FUNCTION
FV
GAT
GATEWAY
GAUGE_COLOR
GAUGE_INTERVAL
GAUGE_VISIBLE
GENERATE_TOC
GET
GETDATE
GETK
GETKEY
GETPROP
GETPROPERTY
GETVAL
GLITTER_LEFT_TO_RIGHT
GLITTER_TOP_LEFT_TO_BOTTOM_RIGHT
GLITTER_TOP_TO_BOTTOM
GOT
GOTO
GOURL
GRA
GRADIENTCOLORSTART

GRADIENTCOLORSTOP
GRADIENTENDCOLOR

IFGT
IFLT
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GRADIENTSTARTCOLOR
GRANT
GRAPHIC_DATA_IN_BINARY
GRAY
GRAYSCALE
GRE
GREEN
GRIDLINES
GRO
GROUP
GROUPBORDERSIZE
GROUPED
GROUPINDEX
GUID
HAV
HAVING
HEA
HEADING
HEADINGS
HEIGHT
HEL
HELP
HIDE_MENUBAR
HIDE_TOOLBAR
HIDE_WINDOW_UI
HIDE_WINDOWUI
HIDESCROLLBARS
HIDESELECTION
HIGHLIGHTCOLOR
HIGHLIGHTFOCUS
HIGHLIGHTFOCUSCOLOR
HINT
HINT_BACK_COLOR
HINT_FONT_BOLD
HINT_FONT_COLOR
HINT_FONT_ITALIC
HINT_FONT_NAME
HINT_FONT_SIZE
HINT_FONT_STRIKEOUT
HINT_FONT_UNDERLINE
HORZEXTENT
HORZSCROLLBAR
HOST
HOTTRACK
HOTTRACKCOLOR
HOVERTIME
HTML
ICAP
ICHAR
ICON
ICON_FILE
IDAY
IDE
IDENTIFIED
IDIM
IDOY
IDQ
IDQUOTES
IDWK
IF
IFEQ
IFEX
IFEXISTS

IFNU
IFNULL
IFRC
IFWINDOW
IHA
IHASH
IHR
IIN
IINFO
ILY
IMAGE_DPI
IMAGE_FOLDER
IMAGE_FORMAT
IMAGE_HEIGHT
IMAGE_WIDTH
IMAGEMARGIN
IMAGESTYLE
IMIN
IMON
IMPO
IMPORT
IN
INACTIVECOLOR
INCLUDE_HYPERLINKS
INCLUDE_IMAGES
INCLUDE_LINES
INCLUDE_RICH_TEXT
INCLUDE_RICHTEXT
INCLUDE_SHAPES
INCREMENT
INCREMENTALDISPLAY
INDE
INDENT
INDEX
INDEXES
INDI
INDIC
INDICATOR
INIT
INITPOS
INP
INPUT
INPUT_FILE
INS
INSERT
INSERTHINT
INT
INTE
INTEGER
INTEGERSONLY
INTENSITY
INTERSECT
INTERVAL
INTO
IS
ISA
ISALPHA
ISCOMPILED
ISD
ISDIGIT
ISEC
ISL
ISLOWER

ISRUNTIME
ISS

LINK_FONT_ITALIC
LINK_FONT_NAME



Preparation 9

Copyright © 1982-2014 R:BASE Technologies, Inc.

ISSPACE
IST
ISTAT
ISU
ISUPPER
ITEMCNT
ITEMCOUNT
ITEMHEIGHT
ITEMINDEX
IWOY
IYR
IYR4
JAVA_SCRIPT_FILE_NAME
JDA
JDATE
JOI
JOIN
JPEG_QUALITY
JUMP
JUMPTO
KEY
KEYB
KEYBOARD
KEYMAP
KEYS
KEYVALUES
KEYWORDS
LAB
LABEL
LABELS
LANGUAGE
LAS
LAST
LASTCHAR
LASTHINT
LASTK
LASTKEY
LAUNCH
LAVG
LAY
LAYOUT
LBL
LBLPRINT
LCFOLD
LEF
LEFT
LEGEND_VISIBLE
LIG
LIGHT
LIGHTTEXTSTYLE
LIK
LIKE
LIM
LIMIT
LIMITNUMALLOC
LINE_SPACE
LINEE
LINEEND
LINES
LINESPERROW
LINK_BACK_COLOR
LINK_FONT_BOLD
LINK_FONT_COLOR

LINK_FONT_SIZE
LINK_FONT_STRIKEOUT
LINK_FONT_UNDERLINE
LINK_H_BACK_COLOR
LINK_H_FORE_COLOR
LINK_IMG_FILE_FIRST
LINK_IMG_FILE_LAST
LINK_IMG_FILE_NEXT
LINK_IMG_FILE_PREV
LINK_TEXT_FIRST
LINK_TEXT_LAST
LINK_TEXT_NEXT
LINK_TEXT_PREV
LINKTARGET
LIS
LIST
LIST_BACK_COLOR
LIST_BOLD
LIST_FONT_COLOR
LIST_FONT_NAME
LIST_FONT_SIZE
LIST_ITALIC
LIST_STRIKEOUT
LIST_UNDERLINE
LISTA
LISTATT
LISTCOUNT
LISTITEMS
LISTITEMSADD
LISTITEMSADDDELIMITEDTEXT
LISTITEMSCLEAR
LISTITEMSDELETE
LISTITEMSREFRESH
LISTOPEN
LISTREL
LJS
LMAX
LMIN
LOA
LOAD
LOAD_FROM_FILE
LOAD_GLYPH_FROM_FILE
LOADIMAGEFROMFILE
LOADWINDOW
LOB
LOC
LOCK
LOG
LONG
LOO
LOOKUP
LOOKUPS
LOWER
LTRIM
LUC
MAG
MAGENTA
MAILADRESS
MAKECLICK
MANO
MANOPT
MANY
MARGIN

MARGIN_BOTTOM
MARGIN_LEFT

MOVEUP
MPW
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MARGIN_RIGHT
MARGIN_TOP
MASK
MAX
MAXFREE
MAXI
MAXIMIZE
MAXIMIZED
MAXIMUM
MAXLENGTH
MAXNUMALLOC
MAXTRANS
MD
MDI
MEMORY
MEN
MENU
MERGE
MES
MESSAGE
MESSAGE_BACK_COLOR
MESSAGE_BOLD
MESSAGE_COLOR
MESSAGE_FONT_BOLD
MESSAGE_FONT_COLOR
MESSAGE_FONT_ITALIC
MESSAGE_FONT_NAME
MESSAGE_FONT_SIZE
MESSAGE_FONT_STRIKEOUT
MESSAGE_FONT_UNDERLINE
MESSAGE_ITALIC
MESSAGE_STRIKEOUT
MESSAGE_UNDERLINE
MESSAGES
METER_COLOR_OFF
METER_COLOR1
METER_COLOR2
METER_COLOR3
METER_MAX_VALUE
METER_TYPE
METER_VALUE
METER_VISIBLE
MICRORIM_RETURN
MICRORIM_WALLPAPER
MIN
MINI
MINIMIZE
MINIMIZED
MINIMUM
MINSIZE
MIR
MIRROR
MKDIR
MOD
MODAL
MODULE
MONOCHROME
MOU
MOUSE
MOUSECOL
MOUSEROW
MOVE
MOVEDOWN

MUL
MULTI
MULTILINE
MULTILINEROWS
MULTILINETITLES
MULTIPAGE
MULTISELECT
NAM
NAME
NAMEWIDTH
NAV_ORIENT
NAV_POS
NAV_SHOW
NAV_TYPE
NAVY
NEW
NEWP
NEWPAGE
NEWR
NEWROW
NEXT
NEXTHINT
NEXTR
NEXTROW
NEXTT
NEXTTAB
NINT
NOC
NOCHE
NOCHECK
NOCHG
NOE
NOECHO
NOF
NOFILL
NOHEAD
NOHEADER
NON
NON_FULL_SCREEN_PAGE_MODE
NONE
NONUM
NOQ
NOQBE
NOR
NORMAL
NORMALIZE
NOS
NOSCROLL
NOT
NOTE
NOTE_PAD
NUL
NULL
NULLASUNCHECKED
NUM
NUME
NUMERIC
OddColor
OF
OFF
OLDLINE
OLDMENUS
ON

ONE_COLUMN
ONELINE

PERCENTAGE
PIXELFORMAT
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OPE
OPEN
OPEN_AFTER_SAVE
OPENCURRENTDIR
OPENED
OPENEDHEIGHT
OPT
OPTIMIZATION
OPTIMIZE_FOR_IE
OPTION
OPTIONS
OR
ORD
ORDER
ORIENTATION
OUT
OUTER
OUTP
OUTPUT
OUTPUT_FILE
OUTPUT_FORMAT
OUTPUT_SCRIPTS_TO_JAVA_SCRIPT_FILE
OUTPUT_STYLES_TO_CSS_FILE
OWN
OWNER
OWNER_PASSWORD
PAC
PACK
PAG
PAGE
PAGE_COUNT
PAGE_END_LINES
PAGE_LAYOUT
PAGE_LAYOUT_SINGLE_PAGE
PAGE_MODE
PAGE_RANGE
PAGE_TRANSITION_EFFECT
page_width
PAGECOL
PAGECOUNT
PAGEMODE
PAGENO_VISIBLE
PAGEROW
PAGESIZE
PANELBORDER
PAPER_HEIGHT
PAPER_NAME
PAPER_WIDTH
PAS
PASCAL
PASSIVECOLOR
PASSTAB
PASSTHROUGH
PASSWORD
PASSWORDCHAR
PASSWORDS
PasteFromClipboard
PAU
PAUSE
PDF
PEN_COLOR
PENWIDTH

PKE
PKEYS
PLA
PLAINTEXT
PLAYBACK
PLI
PLU
PLUGIN
PLUGINS
PLUS
PMT
POI
POINTER
POPUP_CALENDAR_BACK_COLOR
POPUP_CALENDAR_DATE_BUTTONS_COLOR
POPUP_CALENDAR_DATE_BUTTONS_FONT_COLOR
POPUP_CALENDAR_DAYS_COLOR
POPUP_CALENDAR_DAYSOFWEEK_COLOR
POPUP_CALENDAR_FILLDAYS_COLOR
POPUP_CALENDAR_LINES_COLOR
POPUP_CALENDAR_MONTH_AREA_COLOR
POPUP_CALENDAR_MONTH_AREA_FONT_COLOR
POPUP_CALENDAR_SELBACK_COLOR
POPUP_CALENDAR_SELFORE_COLOR
POPUP_CALENDAR_TODAYFRAME_COLOR
POPUP_CAPTION
POPUP_CLOCK_BACK_COLOR
POPUP_CLOCK_FACE_COLOR
POPUP_CLOCK_HANDS_COLOR
POPUP_CLOCK_HOURTICKS_COLOR
POPUP_CLOCK_MINUTETICKS_COLOR
POPUP_CLOCK_NUMBERS_COLOR
POPUP_DIALOG_TYPE
POPUP_DISTINCT
POPUP_ENABLED
POPUP_LINES
POPUP_LIST_BACK_COLOR
POPUP_LIST_FONT_BOLD
POPUP_LIST_FONT_COLOR
POPUP_LIST_FONT_ITALIC
POPUP_LIST_FONT_NAME
POPUP_LIST_FONT_SIZE
POPUP_LIST_FONT_STRIKEOUT
POPUP_LIST_FONT_UNDERLINE
POPUP_LIST_MULTISELECT
POPUP_RETURN_COLUMN
POPUP_RETURN_TYPE
POPUP_SELECT
POPUP_SHOW_LINES
POPUP_TABLE
POPUP_TITLE_BACK_COLOR
POPUP_TITLE_FONT_BOLD
POPUP_TITLE_FONT_COLOR
POPUP_TITLE_FONT_ITALIC
POPUP_TITLE_FONT_NAME
POPUP_TITLE_FONT_SIZE
POPUP_TITLE_FONT_STRIKEOUT
POPUP_TITLE_FONT_UNDERLINE
POPUP_TITLE_TEXT
POPUP_WHERE
POPUP_WINDOW_BACK_COLOR
POSFIXED

POSITION
POST

RBBE
RBBEDIT
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POSTHINT
PRE
PRECISION
PREF
PREFIX
PRESENTATION_MODE
PREVENT_FULL_OPEN
PREVIEW_BACKGROUND_COLOR
PREVIEW_CAPTION
PREVR
PREVROW
PREVT
PREVTAB
PRI
PRIM
PRIMARY
PRINT
PRINTER
PRINTER_NAME
PRIO
PRIOR
PRIORHINT
PRIV
PRIVILEGES
PRN
PRNSETUP
PRO
PROC
PROCEDURE
PROCESSMESSAGE
PROGRESS
PROGRESSIVE_ENCODING
PROJECT
PROM
PROMPT
PROMPTS
PROP
PROPERTY
PROPORTIONAL
PTR
PUB
PUBLIC
PUT
PV
QBE
QUA
QUALCOLS
QUALITY
QUE
QUERY
QUI
QUIT
QUO
QUOTES
RAGGEDRIGHT
RAN
RANDOM
RATE
RBA_FORM
RBADMIN
RBAPP
RBASE_FORM
RBASE_FORM_ACTION

RBD
RBDEFINE
RBE
RBEDIT
RBGS
RBGSIZE
RBL
RBLABELS
RBS
RBSIZE
RBSYNC
RBSYSTEM
RBTI_NOSTATUS
RBTI_PRNSETUP
RD
RDATE
REA
READ
READONLY
REAL
RECA
RECALC
RECOR
RECORD
RECOV
RECOVER
RECYCLE
RED
REDE
REDEFINE
REF
REFERENCES
REFF
REFRESH
REFRESHFILES
REFRESHHINT
REFRESHLIST
REL
RELA
RELATIVE
RELOAD
REM
REMOVE
REN
RENAME
REP
REPAINTGRID
REPETITIONS
REPL
REPLACE
REPLY_TO
REPO
REPORT
REPORTS
RES
RESE
RESET
RESETROW
REST
RESTORE
RESTOREDIRECTORY
RestoreOrderBy
RET

RETURN
REV

SDIS
SDISCONNECT
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REVERSE
REVOKE
RHIDE
RICHTEXT_ENCODING_TYPE
RIG
RIGHT
RJS
RMD
RMDIR
ROL
ROLLBACK
ROLLOUT
ROUND
ROW
ROWCOUNT
ROWINDENT
ROWLOCKS
ROWOVERLAP
ROWS
ROWSELECT
ROWSHEIGHT
RPHONE
RPW
RSHOW
RTIME
RTRIM
RUL
RULE
RULES
RUN
SAT
SATT
SATTACH
SAV
SAVE_TO_BMP
SAVE_TO_FILE
SAVE_TO_JPG
SAVE_TO_PDF
SAVE_TO_PNG
SAVE_TO_VML
SAVEROW
SCALEBY
SCALEX
SCALEY
SCH
SCHEMA
SCO
SCON
SCONNECT
SCR
SCRATCH
SCREEN
SCRO
SCROLL
SCROLLDELAY
SCROLLHINTS
SCROLLING
SCROLLOPPOSITE
SCROLLWIDTH
SDE
SDET
SDETACH
SDI

SECARROW
SECTION
SEG1COLOR
SEG1COUNT
SEG2COLOR
SEG2COUNT
SEG3COLOR
SEG3COUNT
SEGOFFCOLOR
SEGONCOLOR
SEGSPACING
SEL
SELECT
SELECT_ALL
selectall
SELECTEDCOLOR
selectedstate
SELECTION
SELM
SELMARGIN
SEM
SEMI
SEP_FILE_PER_PAGE
SEQ
SEQUENCE
SER
SERIES_TABLE
SERVER
SET
SET_FOCUS
SET_FOCUS_ASYNC
SETF
SETFOCUS
SFIL
SGET
SHADOWCOLOR
SHADOWDEPTH
SHEET_INDEX
SHEET_NAME
SHO
SHORTNAME
SHOW
SHOW_CANCEL_DIALOG
SHOW_CLOSE_BUTTON
show_editor
SHOW_HELP
SHOW_MAXIMIZE_BUTTON
SHOW_MINIMIZE_BUTTON
SHOW_SETUP_DIALOG
SHOWACCELCHAR
SHOWARROW
SHOWBLINKING
SHOWBUTTONS
SHOWCOLUMNHEADERS
SHOWDOWNPATTERN
SHOWFOCUS
SHOWFOCUSRECT
SHOWGLYPH
SHOWGLYPHS
SHOWGRADIENT
SHOWHIDDENDIRS
SHOWHINT
ShowHorizontalLines

SHOWIMAGE
SHOWLINES

STDCALL
STDEV
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SHOWLONGNAMES
SHOWPERCENT
SHOWRECORDNUMBER
SHOWROOT
ShowSeconds
SHOWSHADOW
SHOWTEXTELLIPSIS
SHOWTEXTURE
SHOWTITLEELLIPSIS
SHOWTODAY
SHOWTODAYCIRCLE
SHOWWEEKNUMBERS
SHOWWORKAREAS
SIGN
SIN
SINGLE
SINGLE_PAGE
SINH
SIZ
SIZE
SKI
SKIP
SLEN
SLOC
SLOCP
SMA
SMALLINT
SMOVE
SNA
SNAP
SOLID_COLOR
SOM
SOME
SOR
SORT
SORTED
SORTM
SORTMENU
SOUNDEX
SOUNDS
SOUNDS_L
SOUNDS_LIKE
SPACEEVENLY
SPACING
SPECIAL
SPECIFICATION_FILE_NAME
SPLIT_HOR_INWARD
SPLIT_HOR_OUTWARD
SPLIT_VERT_INWARD
SPLIT_VERT_OUTWARD
SPUT
SQLCODE
SQLERROR
SQRT
SRPL
SSQL
SSUB
STARTFRAME
STARTUP
STAT
STATICDB
STAY_ON_TOP
STD

STOPFRAME
STORE
STR
STRETCH
STRIM
STRUCTURE
SUB
SUBJECT
SUBTRACT
SUC
SUCCEEDS
SUF
SUFF
SUFFIX
SUM
SUPPRESSSCRIPTERRORS
SWI
SWITCH
SYS
SYS_NEW
SYS_OLD
SYSTEM
TAB
TABENABLED
TABHEIGHT
TABHINTS
TABINDEX
TABLE
TABLES
TABORDER
TABSIZE
TABSTOP
TABVISIBLE
TABWIDTH
TAL
TALLY
TAN
TANH
TASKBARBUTTON
TBLNAME
TDWK
TEAL
TEMP
TEMPORARY
TERM
TERMI
TERMINAL
TEX
TEXT
TEXTRACT
TEXTVALUE
THE
THEMENAME
THEN
TILE
TIM
TIME
TIMEO
TIMEOUT
TIMERENABLED
TIMERINTERVAL
TIT
TITLE

TITLE_BACK_COLOR
TITLE_BOLD

USE_COMPRESSION
USE_OUTLINES
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TITLE_FONT_COLOR
TITLE_FONT_NAME
TITLE_FONT_SIZE
TITLE_ITALIC
TITLE_STRIKEOUT
TITLE_UNDERLINE
TITLES
TMON
TO
TO_LIST
TOC_FILE_NAME
TOL
TOLERANCE
TOOLBAR_VISIBLE
TOOLTIPS
TOP
TOPITEM
TOTALALLOC
TOTALFREE
TOTALLOCKS
TOTALREADS
TOTALWRITES
TRA
TRACE
TRANSACT
TRANSITION_DURATION
TRANSITION_PAGE_RANGE
TRANSPARENCY
TRANSPARENT
TRANSPARENTCOLOR
TRANSPARENTCOLORVALUE
TRAPEZOIDMIN
TRAY
TRIG
TRIGGER
TRIM
TRUE
TURBO
TwelveHourClock
TWO_COLUMN_LEFT
TWO_COLUMN_RIGHT
TYP
TYPE
UDF
UKE
UKEYS
ULC
UNI
UNIO
UNION
UNIQ
UNIQUE
UNL
UNLOAD
UNNAMED
unselect
UPD
UPDATE
UPG
UPGRADE
UPPER
URL
USE

USE_TEXT_LINKS
USE_THUMBS
USECOLOREDTABS
USEGRADIENTS
USER
USER_PASSWORD
USERA
USERAPP
USERID
USI
USING
V
VAL
VALUE
VALUES
VAR
VARBIN
VARBINARY
VARBIT
VARC
VARCHAR
VARI
VARIAB
VARIABLE
VARIABLES
VARIAN
VARIANCE
VARY
VARYING
VER
VERIFY
VERS
VERSION
VERTICALSPACING
VIE
VIEW
VIEWS
VISIBLE
VOID
WAI
WAIT
WAL
WALKMENU
WANTRETURNS
WANTTABS
WEEKNUMBERS
WHE
WHEN
WHENEVER
WHERE
WHI
WHILE
WHILEOPT
WHITE
whole_page
WID
WIDTH
WINAUTH
WINBEEP
WINDOW_BACK_COLOR
WINDOW_CAPTION
WINDOW_STATE
WIPE_BOTTOM_TO_TOP

WIPE_LEFT_TO_RIGHT
WIPE_RIGHT_TO_LEFT
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WIPE_TOP_TO_BOTTOM
WIT
WITH
WOR
WORDWRAP
WORK
WRA
WRAP
WRI
WRITE
WRITECHK
XHTML
YEA
YEAR
YEL
YELLOW
ZebraStripe
ZER
ZERO
ZIP
ZOO
zoom_type
ZOOMEDIT
ZOOMPERCENT
ZOOMPERCENT_VISIBLE

If you are still using a legacy version of R:BASE, it is recommended that you perform these table and
column name changes in that version. After making the table and column names changes, R:BASE will
update the form, report, and label column objects with the appropriate new name. However, if any of the
columns and tables are listed in the form, report, and label variable expressions, you must manually edit
these expressions. 

On paper, record any table and column name changes. Later in the conversion process when you're
updating your command files, you will need to make these necessary name changes for the command
files as well.

1.3 Conversion Tools

For conversion purposes, the Manual Tools are included with the Full Version of R:BASE eXtreme for
Windows. The files are located on the root of the R:BASE eXtreme for Windows CD-ROM in the
"Conversion Tools" folder. The executable programs in the "CONVERT" directory are only used for
converting databases that are older than R:BASE 4.5. The Manual Tools utilities must be executed on a
32-bit operating system. 

Convert Express is a separate product and is sold separately. Convert Express is only used with
R:BASE 2.11, or earlier, databases. Or, if your R:BASE database version is 3.x or 4.0, and you do not
wish to save your forms and reports, then Convert Express will serve your needs. Please call R:BASE
Technologies at 1+724.733.0053 or e-mail sales@rbase.com, if you wish to purchase Convert Express.

mailto:sales@rbase.com
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2 Converting the Database Files

2.1 Recognizing the Database Files

When locating and using the database name in the conversion instructions, be sure to remember that the
"actual" database name for .RBS and .RBF files does not include the "1", "2", or "3", which is located
before the file extension. For example, a R:BASE 3.1 database with the name SALES will have the
database files SALES1.RBF, SALES2.RBF, and SALES3.RBF, but the database name is still just "SALES".
In the steps below where the "dbname" is required in the command syntax, use only the "actual"
database name. 

To use this document you will need to know which version of R:BASE you are upgrading from. To assist
you in getting a rough idea of which version you are starting at, we have included the table below which
lists the various R:BASE file formats. Once you find your R:BASE database version from the table
below, follow the necessary conversion steps in the next section.

R:BASE Database File Formats

4000 / 5000 System V to 4.0

DBNAME1.RBS DBNAME1.RBF

DBNAME2.RBS DBNAME2.RBF

DBNAME3.RBS DBNAME3.RBF

4.5 to 5.0 5.5 to eXtreme 9.5 (32)

DBNAME.RB1 DBNAME.RB1

DBNAME.RB2 DBNAME.RB2

DBNAME.RB3 DBNAME.RB3

DBNAME.RB4

Turbo V-8 to 
eXtreme 9.5 (64)

DBNAME.RX1

DBNAME.RX2

DBNAME.RX3

DBNAME.RX4

2.2 Conversion Steps

PLEASE REMEMBER TO BACK UP YOUR DATABASE!

The steps required to convert databases to work with R:BASE eXtreme for Windows are described in the
following flow chart. Locate your current R:BASE database file "Starting Version" in the left column and
complete the steps until you reach the bottom. If you are not sure of your database file version, refer to
the Recognizing the Database Files chart above.

In the sections that follow, proceed to the chapter that lists the version you are upgrading from. Your
options include:

Converting from R:BASE 4.0 and Lower Versions to eXtreme 9.5 (32/64)
Converting from R:BASE 4.5 through 9.x Versions to eXtreme 9.5 (32/64)
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2.2.1 Converting from R:BASE 4.0 and Lower Versions to eXtreme 9.5 (32/64)

If you are converting a database from R:BASE 4.0 or lower, you must first following the below
instructions, then proceed to either the "Manual Tools" or "Convert Express" options. 

IMPORTANT: Both "Manual Tools" and "Convert Express" require that the utilities be executed on a 32-
bit operating system. 

Convert Express is a utility that is sold separately which assists in the conversion of R:BASE 2.11 to
version 4.5 when a large number of database are present, as well as other features. If you did not
acquire Convert Express, then follow the "Manual Tools" instructions. 

If you are converting a database at version R:BASE 4.5 and higher or 6.5++ and lower, then proceed to
the steps listed at "Converting from R:BASE 4.5 through 9.x Versions".

All Databases at  Version 4.0 and Lower:
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1. Create a new directory; perhaps something near your root directory on the local drive
(example: "C:\DBTEMP"). 

2. Copy the contents of the "CONVERT" directory, from the installation CD, to your new directory.
 

3. Copy your database files to the new directory.  
4. Continue with your version as listed below. 

Manual Tools

Start at your R:BASE database version, in the bold
font. 

R:BASE 4000 / R:BASE 5000

1. Open a Command Prompt or DOS Prompt
window and navigate to the new directory
created above in Step 1

2. At the Prompt, type: CONVERT dbname  

3. Repeat for all databases
4. Continue with the steps listed at "R:BASE

System V, 2.x and 3.x" 

R:BASE System V, 2.x and 3.x

1. If you have not done so already, open a
Command Prompt or DOS Prompt window
and navigate to the new directory created
above in Step 1

2. At the Prompt, type: DBCONV dbname  

3. Repeat for all databases  
4. Continue with the steps listed at "R:BASE

3.x and 4.0"

R:BASE 3.x or 4.0

1. If you have not done so already, open a
Command Prompt or DOS Prompt window
and navigate to the new directory created
above in Step 1

2. At the Prompt, type: NEWDB dbname
3. Repeat for all databases  
4. Continue with the steps listed at
"Converting from R:BASE 4.5 through 9.x
Versions" 

You can exit the Command Prompt or DOS Prompt
window. Use the EXIT command to exit.

In addition to the original database files, three new
files will be created that have the RB1, RB2, and
RB3 file extensions.

Convert Express

Start at your R:BASE database version, in the bold
font. 

R:BASE 4000 / R:BASE 5000

1. Open a Command Prompt or DOS Prompt
window and navigate to the new directory
created above in Step 1

2. At the Prompt, type: CONVERT dbname  

3. Repeat for all databases
4. Continue with the steps listed at "R:BASE

System V, 2.x and 3.x" 

R:BASE System V, 2.x, 3.x, or 4.0

1. If you have not done so already, open a
Command Prompt or DOS Prompt window
and navigate to the new directory created
above in Step 1

2. At the Prompt, type: CONVEX 
3. Select CONVERT DATABASES  
4. Select ALL FOUND
5. Continue with the steps listed at

"Converting from R:BASE 4.5 through
9.x Versions" 

You can exit the Convert Express.

In addition to the original database files, three new
files will be created that have the RB1, RB2, and
RB3 file extensions.

2.2.2 Converting from R:BASE 4.5 through 9.x Versions to eXtreme 9.5 (32/64)

At this point, you must have R:BASE eXtreme 9.5 installed on your computer. Be sure to review the
R:BASE eXtreme 9.5 Getting Started Guide regarding the installation and set up for your R:BASE
software. The Getting Started Guide is located in the R:BASE program directory.
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If there is no OWNER or Password

1. Install and launch R:BASE eXtreme 9.5
2. Navigate to your database directory using the "Change Current Folder" button (bottom left

corner, folder icon with a green arrow)
3. Go to the R> Prompt window (third button from the left on the Tool Bar, or press [Ctrl]+[R])

4. At the R> Prompt, type:  SET MULTI OFF , then press [Enter]

5. At the R> Prompt, type:  SET STATICDB OFF , then press [Enter]

6.    At the R> Prompt type:   CONVERT DBNAME , then press [Enter]

7. At the R> Prompt, type:  CONNECT DBNAME  , then press [Enter] 

8. At the R> Prompt, type:  SET IDQUOTES=` , then press [Enter]  (the ` quote character is the

reverse single quote, which is next to the "1" and under the tilde "~", on American keyboards

9. At the R> Prompt, type:  DISCONNECT , then press [Enter] 
10.  Perform the "Complete Database Rebuild" instructions below
11. Repeat "Steps 6-10" for all databases

If there is a Username and Password 

1. Install and launch R:BASE eXtreme 9.5
2. Navigate to your database directory using the "Change Current Folder" button (bottom left

corner, folder icon with a green arrow)

3. Go to the R> Prompt window (third button from the left on the Tool Bar, or press [Ctrl]+[R]) 
4. At the R> Prompt, type:  SET MULTI OFF , then press [Enter]

5. At the R> Prompt, type:  SET STATICDB OFF , then press [Enter]

6.    At the R> Prompt, type:  SET USER UserName Password , then press [Enter]

7.    At the R> Prompt type:   CONVERT DBNAME , then press [Enter]    

8. At the R> Prompt, type:  CONNECT DBNAME , then press [Enter]

9. At the R> Prompt, type:  SET IDQUOTES=` , then press [Enter]  (the ` quote character is the

reverse single quote, which is next to the "1" and under the tilde "~", on American keyboards

10. At the R> Prompt, type:  DISCONNECT , then press [Enter]

11.  Perform the "Complete Database Rebuild" instructions below
12. Repeat "Steps 6-11" for all databases

If there is a database OWNER 

1. Install and launch R:BASE eXtreme 9.5
2. Navigate to your database directory using the "Change Current Folder" button (bottom left

corner, folder icon with a green arrow)  
3. Go to the R> Prompt window (third button from the left on the Tool Bar, or press [Ctrl]+[R])

4. At the R> Prompt, type:  SET MULTI OFF , then press [Enter]

5. At the R> Prompt, type:  SET STATICDB OFF , then press [Enter]

6.    At the R> Prompt, type:  SET USER OwnerName , then press [Enter]

7. At the R> Prompt type:   CONVERT DBNAME , then press [Enter]

8. At the R> Prompt, type:  CONNECT DBNAME , then press [Enter] 
9. At the R> Prompt, type:  SET IDQUOTES=` , then press [Enter]  (the ` quote character is the

reverse single quote, which is next to the "1" and under the tilde "~", on American keyboards

10. At the R> Prompt, type:  DISCONNECT , then press [Enter] 
11.  Perform the "Complete Database Rebuild" instructions below
12. Repeat "Steps 6-11" for all databases

Database Rebuild 
In addition to the above conversion steps, the following steps are required to completely rebuild the
database. These steps will be performed in R:BASE eXtreme.

1. Connect to the database and open the R> Prompt.

2. Check the IDQUOTE settings of connected database.

At the R> Prompt, type:
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SHOW CHARACTERS

Notice the last parameter, IDQUOTES

If IDQUOTES is set to NULL, you'll need to change NULL to the appropriate character, such as `
(reversed quote) as following:

SET IDQUOTES= `

3. Unload the entire database. Use the SET USER command below if an OWNER name exists.

At the R> Prompt, type:

SET NULL -0- 
SET USER ownername
OUTPUT filename.ALL 
UNLOAD ALL 
OUTPUT SCREEN

This process will create two files for Windows databases (filename.ALL and filename.LOB), and a
single file for DOS databases.

4. Disconnect the database.

At the R> Prompt, type:

DISCONNECT

5. Now rename the database that was just unloaded in Steps 1-3.

Review the list of Databases in the R:BASE eXtreme Database Explorer, and select the "Rename"
option. Enter a new name for the database.

6. Finally, use R:BASE to rebuild the database by running the .ALL file.

At the R:BASE eXtreme R> Prompt type:

RUN filename.ALL

These steps will build a clean database!

If there is a considerable amount of errors with both rebuilding the structure and/or data, please refer to
the "Database Repair Routine" within the Database Maintenance PDF document in the R:BASE program
directory.

With the database file conversion complete, proceed to the chapter for Converting Forms, Reports, &
Labels.
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3 Converting Forms, Reports, & Labels

At this point in the conversion process, four database files should exist. When connected to a database,
tables will be listed in the R:BASE eXtreme Database Explorer window. You should also be able to
browse the table data with no problems.

Steps can now be taken to convert the existing forms, reports, and labels to R:BASE eXtreme for
Windows. The DOS database forms, reports, and labels can be converted to R:BASE eXtreme.

1. R:BASE eXtreme for Windows should be launched.
2. Connect to the database by selecting "Database" > "Connect to Database..." from the main Menu

Bar. 

You will be prompted to locate your database files where they are stored on your computer.
Once connected to your database, you will see the database name listed across the top of the
R:BASE eXtreme program caption, in brackets.

Throughout the following instructions, there will be areas of the R:BASE interface that will require you to
know what is being referred to (i.e. Database Explorer, Group Bar, Tool Bar, Menu Bar, etc.). For a quick
description as to what these objects are, please read the "Introduction" page of the R:BASE eXtreme
Tutorial before continuing. To open the Introduction page, select "Help" > "R:BASE Tutorial" from the
R:BASE main Menu Bar.

Once you have completed reading the Introduction page, close the window and go to the next section, 
Converting Forms.

Proceed to the next chapter for converting Forms, Reports, & Labels. 

3.1 Converting Forms

You should now be looking at the R:BASE window with the Database Explorer displayed. To confirm, you
will see the main R:BASE caption read the "R:BASE eXtreme", then your database name listed in square
brackets, then "R:BASE Database Explorer" listed in square brackets. 

If you do not see your database listed in brackets, then connect to it now by selecting "Database" >
"Connect to Database..." from the main Menu Bar. You will be prompted to locate your database
files where they are stored on your computer. Once connected to your database, you will see the
database name listed in the R:BASE eXtreme program caption, in brackets.

If you do not see "R:BASE Database Explorer" listed in square brackets, then select the "Database
Explorer" button on the main Tool Bar. It is the first button on the left and the hint displayed will
read "Database Explorer".

At the Database Explorer window, you will see the "Group Bar" listed on the left side of the window
containing various menu options of R:BASE database modules (i.e. Tables, Views, Forms, etc.)

1. Click on the "Forms" menu option of the Group Bar (figure 1) and select the "Convert Form(s)..."
sub menu option (figure 2). 
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(figure 1)

(figure 2) 

Upon selecting this option, a dialog will appear that may contain a list of the available forms to
convert (figure 3). The forms listed are Windows-based forms that were created in a previous
Windows version of R:BASE. 
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(figure 3)

2. Individual forms can be selected and converted. Multiple forms can be converted by holding the
[Ctrl] key and selecting individual form names. Or pressing the [Ctrl]+[A] keys will select all
listed forms. Press the "OK" button to convert the selected forms. 

The form(s) will convert and will be displayed in the Database Explorer. 

3. The database may contain DOS forms. Select the "DOS Forms" check box. The dialog may now
contain a list of the available DOS forms to convert (figure 4). Any forms listed are DOS-based
forms that were created in a previous DOS version of R:BASE. 

(figure 4)

4. The "Properties" button provides a form conversion option to change single and double line
characters to blank spaces (figure 5). 
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(figure 5)

The following is an example of a form that was converted with this setting unchecked. This display
may be beneficial in the conversion process to help see how a form may have been divided into
sections. 

5. Like with the Windows-based forms, the DOS forms can be individually selected and converted.
Multiple forms can be converted by holding the [Ctrl] key and selecting individual form names. Or
pressing the [Ctrl]+[A] keys will select all listed forms. Press the "OK" button to convert the
selected forms.

At this point, you can now enter the Form Designer to view and make changes to the forms. There are 
Issues and Suggestions to review for the converted forms. However, since many of the instructions
below refer to specific control/object names and require a basic understanding of the Form Designer, it is
recommended that you perform the conversions of the remaining modules (i.e. reports, labels), and then
complete the R:BASE Tutorial before continuing. 

From the Main Menu, choose "Help" > "R:BASE Tutorial". This tutorial covers step-by-step instructions on
building a complete database and application from scratch providing the R:BASE relational logic as it
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adhere's to Dr. Codd's relational model. This is where one would learn how to quickly adapt to the
R:BASE interface!

Issues and Suggestions

Form Lookup Variables
The "Lookup Variable" is now truly a "Lookup" variable, and is not to be changed. All expressions, if
based on lookup variables, will be evaluated and refreshed INSTANTLY. Prior to version 7.x, this was
not the case. Previously, the form variables must  be refreshed with the RECALC VARIABLES
command each time variables were to be refreshed. To achieve the same results in R:BASE eXtreme,
then do NOT use form defined variables, but rather EEPs to declare variables with the SET VARIABLE
command, which can execute when needed and with the flexibility to change the variables accordingly.

Form Variables
Form variables that perform calculations or combine a number of values should be enclosed in
parenthesis. If error messages are displayed for variables performing calculations, like the one below,

2 : CURRENCY    vTotal = price * quantity

add parenthesis as follows:

2 : CURRENCY    vTotal = (price * quantity)

Multi-Page Form with Push Buttons
When converting a multiple page form, the different "pages" will be placed on a Tab Control, with each
page placed upon a separate "tab". Any Push Buttons on the form that use a predefined "Next Page"
or "Previous Page" EEP will appear on the new form, however will have no action assigned to them.
This is because there is technically no longer a "page" to move to with regards to the behavior of a
Tab Control. 

Lookup Variable Tip
Within the R:BASE eXtreme Form Designer there is an option to run a series of commands (or Action)
for a form before the Form Designer is launched. In the Form Designer, choose "Layout" from the
Menu bar, the select "On Before Design Action...".

This will run a series of commands, which can include the creation of variables that Lookup Variables
are based upon, to avoid annoying error messages when the form is opened in the designer. An

example of a lookup variable based upon another variable would be... 

1 : TEXT    vCompany = Company IN Customer WHERE CustID =
.vCustID

The error message appears because the variable vCustID is not defined. Adding the following SET
VAR command to the "On Before Design Action..." will alleviate this error message:

SET VAR vCustID INTEGER

The "On Before Design Action..." is listed under "Layout" on the main Menu Bar.

NOTE: From inside the Form Designer, you can launch the Form Designer help file by pressing the [Shift]
+[F1] hot keys.

3.2 Converting Reports

You should now be looking at the R:BASE window with the Database Explorer displayed. To confirm, you
will see the main R:BASE caption read the "R:BASE eXtreme", then your database name listed in square
brackets, then "R:BASE Database Explorer" listed in square brackets. 

If you do not see your database listed in brackets, then connect to it now by selecting "Database" >
"Connect to Database..." from the main Menu Bar. You will be prompted to locate your database
files where they are stored on your computer. Once connected to your database, you will see the
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database name listed in the R:BASE eXtreme program caption, in brackets.

If you do not see "R:BASE Database Explorer" listed in square brackets, then select the "Database
Explorer" button on the main Tool Bar. It is the first button on the left and the hint displayed will
read "Database Explorer".

At the Database Explorer window, you will see the "Group Bar" listed on the left side of the window
containing various menu options of R:BASE database modules (i.e. Tables, Views, Forms, etc.)

1. Click on the "Reports" menu option of the Group Bar (figure 1) and select the "Convert Report
(s)..." sub menu option (figure 2). 

(figure 1)

  
(figure 2)

Upon selecting this option, a dialog will appear that may contain a list of the available reports to
convert (figure 3). The reports listed are Windows-based reports that were created in a previous
Windows version of R:BASE. 
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(figure 3)

2. Individual reports can be selected and converted. Multiple reports can be converted by holding
the [Ctrl] key and selecting individual report names. Or pressing the [Ctrl]+[A] keys will select all
listed reports. Press the "OK" button to convert the selected reports. 

The report(s) will convert and will be displayed in the Database Explorer. 

3. The database may contain DOS reports. Select the "DOS Reports" check box. The dialog may
now contain a list of the available DOS reports to convert (figure 4). Any reports listed are DOS-
based reports that were created in a previous DOS version of R:BASE. 

(figure 4)

4. The "Properties" button provides report conversion options to change single and double line
characters to blanks, a pass setting, and margins (figure 5). 
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(figure 5)

Maintaining single and double lines in the conversion process may help see how a report was
divided into sections. The pass setting processes system variables once or twice are the report is
generated. For DOS reports, the default is one pass. For Windows reports, the default pass setting
is two. Margins in DOS reports begin at zero. The margin can be changed for any custom reports.

5. Like with the Windows-based reports, the DOS reports can be individually selected and converted.
Multiple reports can be converted by holding the [Ctrl] key and selecting individual report names.
Or pressing the [Ctrl]+[A] keys will select all listed reports. Press the "OK" button to convert the
selected reports.

The report(s) will convert and will be displayed within the Database Explorer. 

At this point, you can now enter the Report Designer to view and make changes to the reports. There
are Issues and Suggestions to review for the converted reports. However, since many of the instructions
below refer to specific control/object names and require a basic understanding of the Report Designer, it
is recommended that you perform the conversions of the remaining modules (i.e. forms, labels), and
then complete the R:BASE Tutorial before continuing. 

From the Main Menu, choose "Help" > "R:BASE Tutorial". This tutorial covers step-by-step instructions on
building a complete database and application from scratch providing the R:BASE relational logic as it
adhere's to Dr. Codd's relational model. This is where one would learn how to quickly adapt to the
R:BASE interface!

Issues and Suggestions

Sub-Totals and Totals
To calculate sub-totals and totals of table columns, Aggregate Variables have always been used to
perform this job. Now, the R:BASE eXtreme for Windows Report Designer has a built-in object called
DB Calc, which performs these same functions on table columns without creating the extra overhead
of variables. You can replace your Variable Label objects with DB Calc objects in instances where the
Variables Object results will not be used further down in the report. 

#DATE, #TIME, #PAGE, Document, and Page Information
The R:BASE eXtreme for Windows Report Designer now has a System Variable control, which allows
an object to be placed for the current DATE, TIME, Document Name, Print DATE and TIME, or one of
many Page Numbering options. All Variable Label objects whose expression value consists of a system
variable (#DATE, #TIME) should be deleted and replaced with a System Variable control. Any Variable
Label objects whose expression value consists of the #PAGE system variable, you must delete the
variable object and replace that object with a System Variable control.

Report Variables
Report variables that perform calculations or combine a number of values should be enclosed in
parenthesis. If error messages are displayed for variables performing calculations, like the one below,
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2 : CURRENCY    vTotal = price * quantity

add parenthesis as follows:

2 : CURRENCY    vTotal = (price * quantity)

Report Totals
To be sure report totals are calculating correctly on all NULL and not NULL records, make sure the 
ZERO setting is ON. Check the setting under "Settings" > "Configuration Settings".

Printer Control Codes
If DOS or machine printer control codes are used in R:BASE Report variables, they can no longer be
stored in the Report Variables. A control code would appear in the variable list with an expression as
follows: <27 40 115 49 83>

If the control code were used to alter the text on the report (i.e. bold, underline, etc.), the control code
must be deleted. There are many new features in the Windows interface that replace control codes for
altering report text objects. The R:BASE eXtreme for Windows version allows you to perform these
font changes must easier.

If control codes listed in the report control hardware for paper feeds or to open a cash drawer, then
document down the exact code and review the "PCC Label" Control in the Report Designer. This
control will support the same functionality used previously.

Picture Format
For a report object, [] may be displayed in the report preview. In R:BASE for DOS and R:BASE for
Windows versions prior to 7.x, a "Picture Format" option was available. The option allowed the
justification of the value and several formatting options based upon the data type of the object. For
example, to add the justification a [>], or [<] was used to right/left justify. 

In R:BASE eXtreme, this feature is called "Display Format", which still offers several formatting options
for report objects based upon the data type of the object. While the formatting option is still supported,
the justification option is no longer supported in the previous context, within the "Display Format"
settings. To right/left/center justify text of an object, use the "Format" tool bar which supports many
text formatting options. 

If you see [] listed in your report preview for a report object, you must right click on the object, select
"Display Format", and remove the [] characters. 

Page Setup
For DOS to Windows conversions, the default page size setting is set to it's largest values in order to
make sure no objects are lost in the conversion process. You must make sure you alter your page
settings back to your desired values in order for your reports to print correctly. 

To alter the page size settings, follow the below instructions:

1. Select "File" > "Page Setup..." from the main Menu Bar.
2. Select the "Paper Size" tab
3. For Portrait orientation reports, the Width should be set to "8.5".
4. For Landscape orientation reports, the Height should be set to "8.5".

From this dialog, you can also adjust your report margins from the "Margins" tab.

After making any changes, make sure that all of your report objects are located within the defined
page size settings and margins. Otherwise, R:BASE will display a warning that "Controls beyond the
new page width will be deleted." In this case, select "Cancel" to avoid losing any controls. Then move
your controls within your desired page settings and then make your page size setting changes again. 

Report Preview Tip
The "Report Preview" tab will display a preview of your report as it may appear when you send the
report to the printer or screen. Before selecting the tab, you must make sure that there are no errors
listed in your Report variables, otherwise, you will receive an error message for every error listed
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multiplied by the number of records displayed in the Report Preview window.  

What you can do to limit the number of rows displayed in the Report Preview window, thus limiting the
number error messages. To do so, alter the Report Default settings for how many rows are displayed
when previewing a report.

1. Select "Settings" > "Report/Label Designer" > "Default Settings..." from the main Menu Bar.
2. Alter the value for "Row Count for Preview:" to a smaller value other than 100; perhaps to 10.

Lookup Variable Tip
Within the R:BASE eXtreme Report Designer there is an option to run a series of commands (or
Action) for a report before the Report Designer is launched. In the Report Designer, choose "Report"
from the Menu bar, the select "Actions" > "On Before Design...".

This will run a series of commands, which can include the creation of variables that Lookup Variables
are based upon, to avoid annoying error messages when the form is opened in the designer. An

example of a lookup variable based upon another variable would be... 

1 : TEXT    vCompany = Company IN Customer WHERE CustID =
.vCustID

The error message appears because the variable vCustID is not defined. Adding the following SET
VAR command to the "On Before Design Action..." will alleviate this error message:

SET VAR vCustID INTEGER

The "On Before Design..." action is located under "Report" > "Actions" on the main Menu Bar.

NOTE: From inside the Report Designer, you can launch the Report Designer help file by pressing the
[Shift]+[F1] hot keys.

3.3 Converting Labels

You should now be looking at the R:BASE window with the Database Explorer displayed. To confirm, you
will see the main R:BASE caption read the "R:BASE eXtreme", then your database name listed in square
brackets, then "R:BASE Database Explorer" listed in square brackets. 

If you do not see your database listed in brackets, then connect to it now by selecting "Database" >
"Connect to Database..." from the main Menu Bar. You will be prompted to locate your database
files where they are stored on your computer. Once connected to your database, you will see the
database name listed in the R:BASE eXtreme program caption, in brackets.

If you do not see "R:BASE Database Explorer" listed in square brackets, then select the "Database
Explorer" button on the main Tool Bar. It is the first button on the left and the hint displayed will
read "Database Explorer".

At the Database Explorer window, you will see the "Group Bar" listed on the left side of the window
containing various menu options of R:BASE database modules (i.e. Tables, Views, Forms, etc.)

1. Click on the "Labels" menu option of the Group Bar (figure 1) and select the "Convert Label(s)..."
sub menu option (figure 2). 
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(figure 1)

(figure 2)

Upon selecting this option, a dialog will appear that may contain a list of the available labels to
convert (figure 3). The labels listed are Windows-based labels that were created in a previous
Windows version of R:BASE. 
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(figure 3)

2. Individual labels can be selected and converted. Multiple labels can be converted by holding the
[Ctrl] key and selecting individual label names. Or pressing the [Ctrl]+[A] keys will select all
listed labels. Press the "OK" button to convert the selected labels. 

The label(s) will convert and will be displayed in the Database Explorer. 

3. The database may contain DOS labels. Select the "DOS Labels" check box. The dialog may now
contain a list of the available DOS labels to convert. Any labels listed are DOS-based labels that
were created in a previous DOS version of R:BASE. The "Properties" button provides label
conversion options to change single and double line characters to blanks, a pass setting, and
margins (figure 5). 

Maintaining single and double lines in the conversion process may help see how a label was
divided into sections. The pass setting processes system variables once or twice are the label is
generated. For DOS labels, the default is one pass. For Windows labels, the default pass setting is
two. Margins in DOS labels begin at zero. The margin can be changed for any custom reports.

4. Like with the Windows-based labels, the DOS labels can be individually selected and converted.
Multiple labels can be converted by holding the [Ctrl] key and selecting individual label names. Or
pressing the [Ctrl]+[A] keys will select all listed labels. Press the "OK" button to convert the
selected labels.

The label(s) will convert and will be displayed within the Database Explorer. 

At this point, you can now enter the Label Designer to view and make changes to the labels. There are 
Issues and Suggestions to review for the converted labels. However, since many of the instructions
below refer to specific control/object names and require a basic understanding of the Label Designer, it
is recommended that you perform the conversions of the remaining modules (i.e. forms, reports), and
then complete the R:BASE Tutorial before continuing. 

From the Main Menu, choose "Help" > "R:BASE Tutorial". This tutorial covers step-by-step instructions on
building a complete database and application from scratch providing the R:BASE relational logic as it
adhere's to Dr. Codd's relational model. This is where one would learn how to quickly adapt to the
R:BASE interface!

Issues and Suggestions

Sub-Totals and Totals
To calculate sub-totals and totals of table columns, Aggregate Variables have always been used to
perform this job. Now, the R:BASE eXtreme for Windows Label Designer has a built-in object called DB
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Calc, which performs these same functions on table columns without creating the extra overhead of
variables. You can replace your Variable Label objects with DB Calc objects in instances where the
Variables Object results will not be used further down in the label. 

#DATE, #TIME, #PAGE, Document, and Page Information
The R:BASE eXtreme for Windows Label Designer now has a System Variable control, which allows an
object to be placed for the current DATE, TIME, Document Name, Print DATE and TIME, or one of
many Page Numbering options. All Variable Label objects whose expression value consists of a system
variable (#DATE, #TIME) should be deleted and replaced with a System Variable control. Any Variable
Label objects whose expression value consists of the #PAGE system variable, you must delete the
variable object and replace that object with a System Variable control.

Label Variables
Label variables that perform calculations or combine a number of values should be enclosed in
parenthesis. If error messages are displayed for variables performing calculations, like the one below,

2 : CURRENCY    vTotal = price * quantity

add parenthesis as follows:

2 : CURRENCY    vTotal = (price * quantity)

Label Totals
To be sure label totals are calculating correctly on all NULL and not NULL records, make sure the ZERO
setting is ON. Check the setting under "Settings" > "Configuration Settings".

Printer Control Codes
If DOS or machine printer control codes are used in R:BASE Label variables, they can no longer be
stored in the Label Variables. A control code would appear in the variable list with an expression as
follows: <27 40 115 49 83>

If the control code were used to alter the text on the label (i.e. bold, underline, etc.), the control code
must be deleted. There are many new features in the Windows interface that replace control codes for
altering label text objects. The R:BASE eXtreme for Windows version allows you to perform these font
changes must easier.

If control codes listed in the label control hardware for paper feeds or to open a cash drawer, then
document down the exact code and review the "PCC Label" Control in the Label Designer. This control
will support the same functionality used previously.

Picture Format
For a label object, [] may be displayed in the label preview. In R:BASE for DOS and R:BASE for
Windows versions prior to 7.x, a "Picture Format" option was available. The option allowed the
justification of the value and several formatting options based upon the data type of the object. For
example, to add the justification a [>], or [<] was used to right/left justify. 

In R:BASE eXtreme, this feature is called "Display Format", which still offers several formatting options
for report objects based upon the data type of the object. While the formatting option is still supported,
the justification option is no longer supported in the previous context, within the "Display Format"
settings. To right/left/center justify text of an object, use the "Format" tool bar which supports many
text formatting options. 

If you see [] listed in your label preview for a label object, you must right click on the object, select
"Display Format", and remove the [] characters. 

Page Setup
For DOS to Windows conversions, the default page size setting is set to it's largest values in order to
make sure no objects are lost in the conversion process. You must make sure you alter your page
settings back to your desired values in order for your labels to print correctly. 

To alter the page size settings, follow the below instructions:

1. Select "File" > "Page Setup..." from the main Menu Bar.
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2. Select the "Paper Size" tab
3. For Portrait orientation reports, the Width should be set to "8.5".
4. For Landscape orientation reports, the Height should be set to "8.5".

From this dialog, you can also adjust your labels margins from the "Margins" tab.

After making any changes, make sure that all of your labels objects are located within the defined
page size settings and margins. Otherwise, R:BASE will display a warning that "Controls beyond the
new page width will be deleted." In this case, select "Cancel" to avoid losing any controls. Then move
your controls within your desired page settings and then make your page size setting changes again. 

Label Preview Tip
The "Label Preview" tab will display a preview of your label as it may appear when you send the label
to the printer or screen. Before selecting the tab, you must make sure that there are no errors listed
in your label variables, otherwise, you will receive an error message for every error listed multiplied
by the number of records displayed in the Label Preview window.  

What you can do to limit the number of rows displayed in the Label Preview window, thus limiting the
number error messages. To do so, alter the Label Default settings for how many rows are displayed
when previewing a label.

1. Select "Settings" > "Report/Label Designer" > "Default Settings..." from the main Menu Bar.
2. Alter the value for "Row Count for Preview:" to a smaller value other than 100; perhaps to 10.

Lookup Variable Tip
Recently added to the R:BASE eXtreme Label Designer is the option to run a command file (or Action)
for a form before the Label Designer is launched. In the Label Designer, choose "Label" from the Menu
bar, the select "Actions" > "On Before Design...".

This allows you to create any variables that Lookup Variables are based upon to avoid annoying error
messages when the label is opened in the designer. An example of a lookup variable based upon
another variable would be... 

1 : TEXT    vCompany = Company IN Customer WHERE CustID =
.vCustID

The error message appears because the variable vCustID is not defined. Adding the following SET
VAR command to the "On Before Design..." action will alleviate this error message:

SET VAR vCustID INTEGER

The "On Before Design..." action is located under "Label" > "Actions" on the main Menu Bar.

NOTE: From inside the Label Designer, you can launch the Label Designer help file by pressing the
[Shift]+[F1] hot keys.
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4 Converting Applications

As R:BASE can be customized for any type of business model or company schema, there have always
been several ways that developers and users could create an application. Actually, if you think of what
an application consists of, you're really looking at a stored series of commands in what are called
command files, which are then combined with other command files to form applications.

R:BASE provides all of the tools you need to produce command files and applications, it is just up to you
to decide which method serves your needs best.

New Application Formats

When building R:BASE databases and applications, R:BASE users have several options as to how they
want to store their "application".

1. Forms - an application can be completely Form driven by storing all of the code in form EEPs. 

2. Application Builder - using the Application Builder interface, an application can be stored in a
.RBA file, separate from the database files. This offers additional security over using just command
files.

3. Command Files - using only code (i.e. CHOOSE, DIALOG, PAUSE, etc), an application can be
entirely written in one or many RMD, APP, CMD, and DAT files.

4. External Form Files - an application can be driven using External Forms, by storing all of the code
in form EEPs. Like an R:BASE Application file (.RBA), External Form Files are stored outside of the
database.

5. All, or some, of the above - an application can consist of all of a few of the above methods to
store R:BASE menu and command files.  

4.1 Application Express Users (.APP)

If you are converting an application that was designed using the Application Express module, the actual
application file consisting of the R:BASE command language (.APP) can be converted in R:BASE
eXtreme. In addition to the .APP file, there will be an .APX and an .API file. You will only need the .APP
or the .API files.

The application may be one large .APP file or several smaller command files; usually with the .CMD file
extension. The standard command file extension was .CMD in early R:BASE versions. It may also be
possible that no file extension is used for the command files. In this case, it is recommended that the
.RMD file extension be added to the file so it may be displayed within the "Command Files" menu within
the Database Explorer's Group Bar.

In R:BASE for Windows, the new file extension standard is .RMD, as more file servers and mail servers
flag the .CMD file extension as a possible virus. Or, if you are using a custom file extension, you can add
the extension to the "File Mask:" field under the "Command Files" menu, so the files will then appear in
this window.

The source code command syntax within the .APP file contains the menus and menu actions of your
custom application in the form of command blocks, menu blocks, and possibly screen blocks. The .APP
file is likely located with your database files. So, when you connect to your database using R:BASE
eXtreme, you will see the .APP file listed under the "Command Files" menu within the Database
Explorer's Group Bar. The files will not be listed under the "Applications" menu as the R:BASE eXtreme
Application Designer will not open legacy Application Express projects for editing. 
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In order to use the .APP file contents in R:BASE eXtreme, a new "Convert Application(s)..." option
has been made available within the "External Forms" portion of the Database Explorer. This feature will
parse through the legacy Windows and DOS legacy application files and converts it to an External Form
File. If the file does not contain $COMMAND blocks or $MENU Blocks, then no conversion will take place.
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Selecting the "Convert Application(s)..." option will display a dialog to select an application file (.APP/
.API). If no files are displayed in the dialog, press the "Cancel" button and select "Utilities" > "Set
Working Directory..." to navigate to the folder where the application files reside. Then, revisit the
"Convert Application(s)..." option. 

Based upon the menu type of the original .APP application file, there are several methods in which
R:BASE will load the menu options into an external form. If the application file used a "pull down" menu
system, then the external form will contain a "Menu Bar". If the application file used a "columnar" menu
system, then the external form can contain either a "Group Bar" or "Tree View". All menu types will
create a collection of user interface groups that contains a list of items to select that can invoke
commands.
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After selecting the "OK" button, the converted external form will appear in the Database Explorer
window. An external form file, with the .RFF file extension, will reside in the folder. If the database and
application is moved to another directory, be sure to move the external form file as well.

To design the external form and see the converted command syntax, select "Design External Form..."
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from Group Bar options. You will then enter the External Form Designer module to alter the external
form.

4.1.1 Menu System Types

Based upon the menu system type of the original .APP application file, R:BASE will create the following
menu system types into the external form:

Menu Bar
Group Bar
Tree View

Menu Bar
After the conversion, a blank gray canvas will be displayed in the External Form Designer. The menu
system and command syntax for each menu item from the application are stored within the external
form file. From the main Menu Bar, select "Layout" > "Design Menu Bar". The Menu Bar Designer will
launch with the application file menus placed accordingly. The Menu Items displayed should match the
$MENU blocks from the originating .APP application file. There may be some menu options that are no
longer used. Make a note of the items as this will save time in the process of reviewing and updating the
command syntax.

A Menu Bar is a horizontal strip that contains lists of available menus for a certain program. In Windows
programs, the menu bar resides at the top of a window. The Menu Bar uses main "Items" which display
across the top of a window, and "Sub-Items" which drop down when the main Item is selected. Items"
and Sub-Items can be used to run a series of R:BASE commands or an external file. From the below
example, "Modify" is the main Item, where "Employees", "Customers", "Transactions", and "Products"
are the Sub-Items. 
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During the conversion, R:BASE loaded the command syntax portions of the .APP application file into the
"Custom Command" portions of the Menu Bar. Any command syntax loaded in a Sub-Item will highlight
the "Edit Custom Command..." button with a yellow background. If no syntax was loaded into the menu
item or sub-item, then the button background will not be yellow. Selecting the "Edit Custom Command..."
button will display the command syntax stored within the Item or Sub-Item. Before running the external
form and selecting any menu options, the command syntax must first be checked.
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Group Bar
After the conversion, the Group Bar will be located on the left side of the form with menu options placed
accordingly. The Group Bar items displayed should match the $MENU blocks from the originating .APP
application file. There may be some menu options that are no longer used. Make a note of the items as
this will save time in the process of reviewing and updating the command syntax.

A Group Bar control is a collection of "groups", that can be opened and closed by using the arrows (looks
like two carat characters ^). Each group contains a list if items that are used to run a series of R:BASE
commands or an external file. The "Groups" are displayed below with a blue font and white background.
The Group Items are located under the Group with a black font. From the below example, "QUOTE FILE
MAIN MENU Ver 4.5" is the first Group, where "VIEW DATA", "PRINT REPORTS", "ENTER NEW QUOTES",
"EDIT QUOTE", "TRANSFER DATA", "COST INFORMATION", and "EXIT QUOTE FILES" are the Items. 
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By right clicking on the Group, and selecting "Object Property [F11], the Group Properties dialog is
displayed. Select the "Items" tab to review the list of item names. Any command syntax loaded in an
Item will highlight the "Edit Custom EEP..." button with a yellow background. If no syntax was loaded into
the Item, then the button background will not be yellow. Selecting the "Edit Custom EEP..." button will
display the stored command syntax. Before running the external form and selecting any menu options,
the command syntax must first be checked. 
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Tree View
After the conversion, the Tree View will be located on the left side of the form with menu options placed
accordingly. The Tree View items displayed should match the $MENU blocks from the originating .APP
application file. There may be some menu options that are no longer used. Make a note of the items as
this will save time in the process of reviewing and updating the command syntax.

A Tree View control is a expandable object with collection of Nodes and Sub-Items that can be expanded
and closed by using the plus and minus characters. Each Node contains a list if items that are used to run
a series of R:BASE commands or an external file. The main "Nodes" are displayed below next to the
minus characters. The Sub-Items are located within the Nodes linked by the dotted lines. From the below
example, "QUOTE FILE MAIN MENU Ver 4.5" is the first Node, where "VIEW DATA", "PRINT REPORTS",
"ENTER NEW QUOTES", "EDIT QUOTE", "TRANSFER DATA", "COST INFORMATION", and "EXIT QUOTE
FILES" are the Sub-Items. 
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By right clicking on the Tree View, and selecting "Object Property [F11], the Tree View Properties dialog
is displayed. Select the "Nodes" tab to review the list of nodes and sub-items. Any command syntax
loaded in an sub-item will highlight the "Edit Custom EEP..." button with a yellow background. If no
syntax was loaded into the sub-item, then the button background will not be yellow. Selecting the "Edit
Custom EEP..." button will display the stored command syntax. Before running the external form and
selecting any menu options, the command syntax must first be checked. 
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4.1.2 Menu Action Types

When a menu option is selected in a legacy application, R:BASE would have provided another menu (i.e.
sub menu) to the user, or would have performed an action. The two type of menus that can be used
include a "menu to a menu" or a "menu to an action."

Menu to a Menu
In some cases, a legacy menu selection was used to jump to another menu. This usually occurs in the
first or second tier of a menu system. In the menu system below, the menu options with the red, orange,
green, and blue lines were used in a DOS menu system to jump to another screen with additional
options. The other three options "ENTER NEW QUOTES", "EDIT QUOTE", and "EXIT QUOTE FILES" do not.
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Since the Windows menu system can display more information, these initial tier options with the red,
orange, green, and blue lines can be removed, and the displayed Group Bar main group captions can be
altered. The end result may look something like this.

Menu to an Action 
The menu to an action will run a series of commands, a Command Block, or an external file. The action
can contain as little as one or two commands, or as much as hundreds of lines of code. 



Converting Applications 51

Copyright © 1982-2014 R:BASE Technologies, Inc.

After the conversion, R:BASE loaded the command syntax portions of the .APP application file into the
"Custom Command" or "Custom EEP" portions of the new menu system (i.e. Menu Bar, Group Bar, Tree
View). Any command syntax loaded will highlight the "Edit Custom Command..." or "Edit Custom EEP"
button with a yellow background. Selecting the button will display the stored command syntax. Before
running the external form and selecting any menu options, the command syntax must first be checked. 

4.1.3 Command Syntax Reference

After the conversion, R:BASE will also load the command block portions of the .APP application file into
the external form as separate "Custom Form Actions". From the main Menu Bar, select "Layout" >
"Custom Form Actions". The placement of the command syntax within the Custom Form Actions serves
as a secondary reference for the command syntax that was used in the legacy application file. 

Since the individual command blocks were already loaded into the appropriate menu system (Menu Bar,
Group Bar, Tree View) during the initial conversion process, the syntax here does not need to be
updated in addition to to the command syntax in the menu system.

The Action Designer, which is used to build and store a library of command blocks, will launch with the
application file $COMMAND blocks loaded separately as individual "Command Name" actions. The
"Description" column will list the $COMMAND block and originating application file.

Within each of the listed items is a block of code. Select or hover the mouse cursor over an item will
display a hint of the stored command syntax. 
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Select the "Edit Command" button to review the command syntax stored within the Custom Form Action. 
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4.2 Command Files

The application may consist of several command files; usually with the .CMD file extension. The standard
command file extension was .CMD in early R:BASE versions. It may also be possible that no file
extension is used for the command files. In this case, it is recommended that the .RMD file extension be
added to the file so it may be displayed within the "Command Files" menu within the Database Explorer's
Group Bar. Now, in R:BASE eXtreme for Windows, the new standard is .RMD as more file servers and
mail servers flag the .CMD file extension as a possible virus. If you are using a custom file extension,
you can add the extension to the "File Mask:" field under the "Command Files" option and they will then
appear in this window.

In order to use your command files in R:BASE eXtreme, you will need to review and update the
command syntax used in the files. Based on the R:BASE version you are upgrading from, there are
additional steps needed to upgrade your command syntax. The older your command files are, then the
more steps will be needed. And, if you are upgrading from a DOS version, there are additional changes
required as well.

With command files as the primary storage format for the code, it is recommended that you open the
R:BASE Editor Help file and review the many features available to add more productivity to the
conversion process.

Also, in R:BASE eXtreme, there are several different ways to run the menus contained within the files.
Please review the several Application Formats available.
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4.3 Updating the Command Syntax

At this point, it is necessary to review and update the command syntax so it can be used within R:BASE
eXtreme. If the syntax is used to RUN another file, then that file must also be checked and updated, if
needed. Based upon the R:BASE version you are upgrading from, there are additional steps needed to
update your application code. The older the application is, then the more steps will be needed. And, if
you are upgrading from a DOS version, there are additional changes required as well. 

You may encounter reserved words (PROJECT, TIME), obsolete commands (SET POINTER), and/or
commands whose syntax has been enhanced for your benefit (PRINT, SELECT, CHOOSE). The time
invested to perform these changes depends on the size of your command files.

There are two important tools included with R:BASE eXtreme that will make your command syntax
changes more pleasant that you think. 

The new R:BASE Editor & R:Style! 

The R:BASE Editor is an editor specifically designed for creation and editing of R:BASE program and

application files, command files, recorded scripts, and text files. It offers these special R:BASE features: 

You can specify settings such as the font, tab stops, and text wrapping. You can also search and
replace text, and print files.  
Any number of program files can be open simultaneously.  
Command files are shown with syntax highlighting with the option of displaying each syntax element
in a different color text.  
Safe tabs -- the Tab key inserts spaces.  
Block commands include block indent, block outdent, block comment out, and block comment in.  
Seamless integration with the R:Style, R:BASE code styler and checker.  
And more...

What is R:Style?

R:Style provides structural error checking, and spelling assistance to help debug your code prior to
running it. R:Style will tell you where in the file to look, and what error to look for! R:Style is not a full
syntax checker, but it is an excellent structure checker, with some syntax checking thrown in as a bonus.
R:Style will find:

 
Mis-terminated lines (= instead of +)  
Illegal or ambiguous commands  
Missing, unmatched, or incorrect quotes  
Unmatched parenthesis  
Missing RETURNs & ENDs, adds them  
Missing or out of place structures, IF, ELSE, ENDIF, SWITCH, ENDSW, WHILE, ENDWHILE, BREAK  
Duplicate block names in APP files  
Illegal use of command words in code or block names  
Ill advised RETURN from within WHILE or SWITCH  
Illegal dotted variables  
Support for finding misspelled or illegal words  
And more...

4.3.1 Table and Column Name Changes

During the initial Preparation stages of the conversion process you were instructed to review change
your table and column names which match any invalid names and reserved words, and to record these
changes on paper.

If you made any table and/or column name changes, the first step in your command syntax updates is
to make these necessary name changes in the application/command files.

For command files, one time-saving suggestion for this task is to use the R:BASE built-in "Find Files"
utility. To launch this command file utility, choose "Utilities" > "Find Files" from the main Menu bar. This
interface will allow you to search your command files for obsolete commands and other words, so you
are not forced to manually search the individual files.
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Keep in mind that whether you are using the R:BASE Editor or another text editor to make these
command syntax updates, it is wise to take advantage of all of the utilities available in the text editor. In
this case where you are replacing keywords, be sure to use any built-in word Search and Replace
utilities to make this task easier. 

For Custom Form Actions, a built-in search utility is available to search all of the code within the Actions.
From within the External Form Designer, select "Edit" > "Find in Custom EEPs" from the main Menu Bar
to search for text within Custom EEPs for the external form. The key combination [Ctrl]+[F] can also be
used used to launch the "Find in Custom EEPs" dialog.
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After the search is complete, a list of external form objects and custom form actions that match the
search will be displayed. The external form object(s) will contain the exact location where the Custom
EEP is in use for the object. The command syntax can be launched in the R:BASE Editor by double
clicking on it, or by selecting the "Edit..." button. The search results can be saved to several output
formats. The "Expand All" check box allows the list of EEPs in the search results to expand for full
viewing.

4.3.2 Obsolete Commands

The following table contains a list of commands that are considered to be obsolete. Most of these
commands have been made obsolete by their SQL Compliant equivalent, and there is no guarantee that
these commands will be supported in future versions of R:BASE. Any code which relies on any of these
commands should be considered dangerous as their use may have unintended and unpredictable
results.

While most items have a direct replacement there are some items that are listed as having no direct
replacement. However it may be possible to replace those commands with other commands that
emulate that functionality. For more information on the "Replacement" commands, refer to the R:BASE
Help "Command Index", or press [F1] from any location in R:BASE.

One suggestion for task this task is to use the R:BASE built-in "Find in Files" utility. To launch this
command file utility, choose "Utilities" > "Find in Files" from the main Menu bar. This interface will allow
you to search your command files for obsolete commands and other words, so you are not forced to
manually search the individual files.
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Obsolete Command Replacement Notes

#FORM_COLUMNNAME RBTI_FORM_COLNAME See also RBTI System
Variables

#FORM_FORMNAME RBTI_FORM_FORMNAME See also RBTI System
Variables

#FORM_TABLENAME RBTI_FORM_TBLNAME See also RBTI System
Variables

AVE() LAVG

BUILD KEY CREATE INDEX

CHANGE UPDATE

CHANGE COLUMN ALTER TABLE

CLOSE DISCONNECT

COLUMNS CREATE TABLE

(CVAL('FORM_ALIAS') RBTI_FORM_ALIAS See also RBTI System
Variables

(CVAL('FORM_CAPTION') GETPROPERTY RBASE_FORM CAPTION

vCaption 

(CVAL('FORM_DATA') RBTI_FORM_COLVALUE See also RBTI System
Variables

(CVAL
('FORM_DATA_TYPE')

RBTI_FORM_DATATYPE See also RBTI System
Variables

(CVAL
('FORM_FIELD_NAME')

RBTI_FORM_COLNAME See also RBTI System
Variables

(CVAL('FORM_NAME') RBTI_FORM_FORMNAME See also RBTI System
Variables

(CVAL('FORM_TABLE') RBTI_FORM_TABLENAME See also RBTI System
Variables

DEFINE CREATE SCHEMA

DELETE KEY DROP INDEX

DELETE FROM #n DELETE FROM TableName
WHERE CURRENT OF CURSOR 

See also DECLARE CURSOR

DISPLAY EDIT USING Used with Variable Forms.

DRAW NONE Used with Variable Forms. No
direct replacement.

ECHO SET ECHO ON

EDIT VAR ... NONE Used with Variable Forms. No
direct replacement.

ENTER VAR ... NONE Used with Variable Forms. No
direct replacement.

ESC [ESC] Used in IF and WHERE clauses
to compare to the Esc key.

Value1 EQ Value2 Value1 = Value2 Value1 equals Value2

EXISTS IS NOT NULL

EXPAND ALTER TABLE

EXPRESS RBAPP

FAILS IS NULL

FILLIN DIALOG In windows consider using
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DIALOG, ENTER or EDIT.

Value1 GE Value2 Value1 >= Value2 Value1 greater than or equal
to Value2.

Value1 GT Value2 Value1 > Value2 Value1 greater than Value2.

IN #n WHERE CURRENT OF CURSOR Used with UPDATE and SET
VAR commands.

Value1 LE Value2 Value1 <= Value2 Value1 less than or equal to
Value2.

Value1 LT Value2 Value1 < Value2 Value1 less than or equal to
Value2.

MAX() LMAX()

MICRORIM_RETURN STP_RETURN

MICRORIM_WALLPAPER NONE This variable was only used
with Forms and Reports

created for R:WEB.

MIN() LMIN()

Value1 NE Value2 Value1 <> Value2 Value1 does not equal Value2.

NEXT FETCH See also DECLARE CURSOR

NOECHO SET ECHO OFF

OPEN CONNECT

OWNER CREATE SCHEMA

PASSWORDS GRANT

PLAYBACK NONE No Replacement.

POPUP/PULLDOWN Menus NONE Use #LIST option of CHOOSE
command. Use LISTOF

command option to create list
of items.

PROMPTS Now DOS Only.

RECORD NONE

REDEFINE ALTER TABLE

REMOVE DROP

RESET NONE No Replacement.

#RETURN NONE Used with Variable Forms. 
No Direct Replacement.

SCREEN RESTORE RECALC VARIABLES Now DOS Only.

SELECT FROM #n SELECT FROM TableName See also DECLARE CURSOR
WHERE CURRENT OF cursor

SET CGA NONE No Replacement.

SET EXTENDED NONE R:BASE always operates in
Extended Mode now.

SET INTENSITY NONE Use "Selected Row" color
option in Scrolling Region

Properties.

SET OLDLINE NONE Use the Page Style option in
Reports.

SET POINTER DECLARE CURSOR

SET RBGSIZE No replacement necessary due
to imbedded form properties.

Command is ignored.
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SET USERAPP NONE No replacement.

SNAP NONE No replacement.

SORTED BY ORDER BY

USER CONNECT IDENTIFIED BY ...

VIEW CREATE VIEW

WRITE In Windows consider using
DIALOG,

PAUSE, ENTER or EDIT.

ZIP RBEDIT RBEDIT RBEDIT is no longer a 
separate executable.

ZIP RBSYNC RBSYNC RBSYNC is no longer a 
separate executable.

4.3.3 Message Dialog Conversion

When converting from DOS to Windows, there are command syntax changes that may or may not
require your attention. 

Instances where you will positively update the command syntax are any locations where DOS message
commands (WRITE) or information prompts (FILLIN) which should be replaced by their Windows
counterpart (PAUSE and DIALOG). 

These commands send simple messages or prompts for data entry to the end user. Your time involved in
this step depends on how much user interaction is in the code. 

To assist you with these replacements, R:BASE eXtreme for Windows includes several syntax builders
for the DIALOG, PAUSE, and CHOOSE commands. They can be accessed from the Menu Bar under
"Utilities" > "Plugins".
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For WRITE, you may have this;

WRITE 'THE PROCESS IS COMPLETE!' AT 10 05

and will replace it with this:

PAUSE 2 USING 'THE PROCESS IS COMPLETE!' CAPTION ' ' ICON INFO

For FILLIN, you may have this;

FILLIN vdte USING 'ENTER DEADLINE DATE: ' AT 12 10

and will replace it with this:



Converting Applications 61

Copyright © 1982-2014 R:BASE Technologies, Inc.

DIALOG 'ENTER DEADLINE DATE:' vdte venke 1 CAPTION 'Question'
ICON QUESTION

The PAUSE and DIALOG samples provided above do not include the many options that are available for
each command to professionally display a message on the screen. Please review the "All About The
Dialog Command" and "All About The Pause Command" PDF documents for the complete syntax
available for each command. The PDF documents are located within the default program directory of
R:BASE eXtreme 9.5 (C:\RBTI\RBG95_32 or C:\RBTI\RBG95_64).

4.3.4 Enhanced Commands

There will be commands whose syntax has been enhanced for your benefit. Most of these commands will
not require mandatory changes other than for an enhanced display (CHOOSE, DIALOG, PAUSE, PRINT),
but the PRINT command is an example of a command that has been enhanced 20 times over, and will
require you to alter your syntax.

You may have this:

OUT PRINTER
PRINT bulletin SORTED BY poscl
OUT screen

and will replace it with this:

PRINT bulletin ORDER BY poscl ASC OPTION PRINTER

or even this:

PRINT bulletin ORDER BY poscl ASC OPTION PRINTER +
|SHOW_CANCEL_DIALOG OFF |TRAY 2 |COLLATION ON +
|COPIES 2 |ORIENTATION LANDSCAPE |PRINTER_NAME HPLaser1345

4.3.5 Unsupported Command Parameters

The application file may have menu blocks where the CHOOSE command is used to run a specific
selected menu, the CHOOSE command parameter "IN MENU.APX". This logic is no longer supported. 

If the approach of the application file conversion is to run the .APP ile as a command file, then the
following method can be used to move the "menu list" into the CHOOSE command with the #LIST
parameter. 

Instead of the following:

CHOOSE PICK1 FROM MENU0000 IN Menu.APX 
--
-- rest of file
--
$MENU
MENU0000
PULLDOWN | |
|Entry|
|Product Quality Plan|
|Inquiry|
|Reports|
|Maintenance|
ENDC



DOS to Windows Database Conversion Guide62

Copyright © 1982-2014 R:BASE Technologies, Inc.

You would use:

CHOOSE PICK1 FROM #LIST 'Entry,Product Quality Plan,Inquiry,Reports,Maintenance' +
TITLE 'SELECT OPTION...' CAPTION 'Main Menu Options' LINES 5 +
OPTION List_Font_Color NAVY|List_Back_Color WHITE|List_Font_Size 12 +
|Title_Font_Color NAVY|Title_Back_Color LIGHT GRAY +
|Window_Back_Color LIGHT GRAY|Title_Font_Size 14

The above will display a choose pop-up window to select the desired option.

Although this will allow the application file to work, we recommend using one of the current application
formats to display a Windows driven menu system.
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5 ODBC Compliance

If you are planning on using ODBC with R:BASE, you must make sure that your character settings are
set correctly by  performing the following:

1. Go to the R> Prompt  
2. Connect to your database

3. Type: SHOW CHAR  

4. Compare your values to the chart below  

Character Set To Description

MANY % Percent Sign

SINGLE _ Underscore

QUOTES ' Single Quote

5. If they do not match, change them by typing SET TYPE=CHAR 
(where TYPE is from the "Character" column and CHAR from the "Set To" column) 

For example, SET MANY=%

Continue below to ensure your database files are Y2K compliant.
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6 Y2K Compliance

For more information on Y2K Compliance please visit our Y2K Page at http://www.rbase.com/support/
y2k/  

To check the Y2K compliance of your database do the following.  

1. Go to an R> Prompt  
2. Connect to your Database  
3. Type SHOW DATE  

Most likely the settings will be as follows... (This is the default for upgraded databases).  

DATE FORMAT MM/DD/YY 
DATE SEQUENCE MMDDYY 
DATE CENTURY 19 
DATE YEAR 0 

If so, then your database is NOT Y2K compliant. To activate the Y2K compliancy features of your
database we recommend the following:  

Set your Format to 4 Y's 
When they are set that way then 1/1/1999 will be seen as a valid year and 1/1/99 will also be a valid
year. If you are set to 2 Y's then only 1/1/99 will be a valid year.  

Set the Date Year to a Convenient Year 
The Date Century and Date Year determine how 2 digit years such as 1/1/99 are handled. To
determine your settings mentally combine the century and the year (in this case 19 and 0 make
1900) and then add 99 (in this case 1999) all two digit years will be interpreted as being between
these dates. Setting Date Year to 80 will result in 19 + 80 giving 1980 and then adding 99 making
2079. Thus all two digit dates will be between 1980 and 2079. For example a date entered as 1/1/60
would be seen as 2060.  

Older versions set to four Y's would see 2 digit dates as being complete four digit years. For example,
1/1/99 would be January First in the year 99. This is known as First Century data. For this reason if
your database is already set to four Y's on the format we recommend using the following command to
check for invalid dates:  

TALLY datecol FROM tablename WHERE datecol < 1/1/1950 

This should build a list of all dates (and how often they occur) that are possibly incorrectly entered
and that you can then deal with. Be careful not to go overboard. For example: if you have your family
tree stored in an R:BASE Database then be careful that you leave Great Grandmother's birthday in
the 1800's where it is supposed to be even though the Tally command above would flag that as an
"invalid" date.

http://www.rbase.com/support/y2k/
http://www.rbase.com/support/y2k/
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7 Database Integrity Routine

Follow the steps below and to validate the integrity of your database.

1. Make a backup copy of the database.

2. Copy the entire database to your "local drive" in a separate folder with at least twice as much
available free disk space.

3. Start R:BASE using the latest version/update and switch the current folder to the appropriate
database folder on your local drive.

4. At the R>, connect to the database:

DISCONNECT 
SET MESSAGES ON 
SET ERROR MESSAGES ON 
SET MULTI OFF

CONNECT dbname
or connect to the database with OWNER password, if any 

CONNECT dbname IDENTIFIED BY owner password 

5. Check the connected database CHARacter settings, especially the IDQUOTES. At the R> prompt:

CLS 
SHOW CHAR

Notice the setting for IDQUOTES (the last item on list).

If this setting is blank/null, make sure to set the IDQUOTES settings to ` (that is a single reversed
quote, on the same key as the ~ tilde). At the R>, type:

SET IDQUOTES=`

6. Now create the unload file with NULL set to -0-. At the R> prompt:

CLS 
SET NULL -0- 
OUTPUT newdb.ALL 
UNLOAD ALL 
OUTPUT SCREEN

This step will create two files (newdb.ALL and newdb.LOB)

7. DISCONNECT, and then rename this database to some other name. At the R> prompt:

DISCONNECT 

RENAME dbname.RX? dbnameBK.RX?
or for RB1 through RB4 files, use:

RENAME dbname.RB? dbnameBK.RB?

8. Now, let's rebuild the fresh database and see if it passes the integrity check. At the R> prompt:

CLS 
RUN newdb.ALL
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Watch the activity and all messages on the screen. Don't fall asleep. You might miss an important
warning. Completion time may vary based on size of the database (number of tables/records/
indexes)

If there were no warnings or error messages, you've got a fresh/healthy database.  

Errors?

1. If there are any warning or -ERROR- message(s), take them seriously. In that case, disconnect and
delete the bad database (built using RUN newdb.ALL). At the R> prompt:

DISCONNECT

DELETE dbname.RX?
or for RB1 through RB4 files, use:

DELETE dbname.RB?

DELETE newdb.ALL 
DELETE newdb.LOB

2. Rename and connect to the previously saved database (Step 7).

RENAME dbnameBK.RX? dbname.RX?
or for RB1 through RB4 files, use:

RENAME dbname.RB? dbnameBK.RB?

CONNECT dbname

3. CORRECT all -ERROR-s accordingly and then repeat Step 6.

4. Do not quit or give up until you see a completely fresh database without any warnings or errors.

If there is a considerable amount of errors with both rebuilding the structure and/or data, please refer to
the "Database Repair Routine" within the Database Maintenance PDF document in the R:BASE program
directory.
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8 Feedback

Suggestions and Enhancement Requests:

From time to time, everyone comes up with an idea for something they'd like their software to do
differently. 

If you come across an idea that you think might make a nice enhancement, your input is always
welcome. 

Please submit your suggestion and/or enhancement request to the R:BASE Developers' Corner Crew
(R:DCC) and describe what you think might make a nice enhancement. In R:BASE, the R:DCC Client is
fully integrated to communicate with the R:BASE development team. From the main Menu Bar, choose
"Help" > "RBG9 R:DCC Client". If you do not have a login profile, select "New User" to create one.

If you have a sample you wish to provide, have the files prepared within a zip archive prior to initiating
the request. You will be prompted to upload any attachments during the submission process.

Unless additional information is needed, you will not receive a direct response. You can periodically
check the status of your submitted enhancement request. 

If you are experiencing any difficulties with the R:DCC Client, please send an e-mail to
rbg9rdcc@rbase.com. 

Reporting Bugs:

If you experience something you think might be a bug, please report it to the R:BASE eXtreme
Developers' Corner Crew. In R:BASE, the R:DCC Client is fully integrated to communicate with the
R:BASE development team. From the main Menu Bar, choose "Help" > "RBG9 R:DCC Client". If you do
not have a login profile, select "New User" to create one.

You will need to describe: 

What you did, what happened, and what you expected to happen
The product version and build 
Any error messages displayed
What computer operating system is in use 
Anything else you think might be relevant 

If you have a sample you wish to provide, have the files prepared within a zip archive prior to initiating
the bug report. You will be prompted to upload any attachments during the submission process.

Unless additional information is needed, you will not receive a direct response. You can periodically
check the status of your submitted bug.

If you are experiencing any difficulties with the R:DCC Client, please send an e-mail to
rbg9rdcc@rbase.com. 

mailto:rbg9rdcc@rbase.com
mailto:rbg9rdcc@rbase.com
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9 Useful Resources

. R:BASE Home Page: http://www.rbase.com

. R:BASE eXtreme Home Page: http://www.rbaseextreme.com

. Up-to-Date R:BASE Updates: http://www.rupdates.com

. Sample Applications: http://www.rbasecommunity.com

. General R:BASE Syntax: http://www.rsyntax.com

. Technical Documents - From The Edge: http://www.razzak.com/fte

. More Sample Applications:   http://www.razzak.com/sampleapplications

. Education and Training: http://www.rbaseuniversity.com

. Upcoming Events: http://www.rbase.com/events

. R:BASE Beginners Tutorial: http://www.rtutorial.com

http://www.rbase.com
http://www.rbaseextreme.com
http://www.rupdates.com
http://www.rbasecommunity.com
http://www.rsyntax.com
http://www.razzak.com/fte
http://www.razzak.com/sampleapplications
http://www.rbaseuniversity.com
http://www.rbase.com/events
http://www.rtutorial.com
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