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1 All About The PAUSE Command

Use the PAUSE command to suspend the running of the command file.

Options

0
Pauses without a message.

1
Displays "Press OK to continue" or any message using the USING option in a dialog box. The R> Prompt
screen then clears with the next keystroke.

2
Same as the 1 option, except the R> Prompt screen does not clear with the next keystroke. 

3
Does not pause the running of the command file and therefore does not wait for the next keystroke. 

4
If a PAUSE 3 dialog already exists only the message will be repainted to avoid flickering. Otherwise, this
is exactly like the PAUSE 3 option. 

FOR n
Sets the pause duration in seconds; n must be a positive integer. Any keystroke interrupts the pause,
regardless of duration. In the absence of a USING clause, no message is displayed. With a USING
clause, the message is displayed in a dialog box

USING 'message'
Displays the specified message in a dialog box. This value can also be passed as a variable. 

Using this default parameter the maximum width of message text in a Windows dialog box is 77
characters and is limited to one line. However, if you need to display a multi-line PAUSE window, you can
create separate lines with the ASCII characters for a carriage return and indent ([Tab] key). A sample is
provided below.

=width
Specifies the wrap width for the dialog box message.

CAPTION 'message'
Specifies the text of the message to display in the dialog box caption. The value can also be passed as a
variable.

ICON value 

Icon "value" Parameter Icon

APPS

ATTENTION
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CONFIRM

ERROR

HELP

INFO

QUESTION

SERIOUS

STOP

WARNING

WINDOWS

Additional OPTION parameters
Additional parameters are available to increase the visual display of the PAUSE window. To use the
graphic PAUSE Builder, choose "Utilities" > "Plugins" > "Internal Plugins" > "PAUSE Builder" from the
main Menu Bar.  All OPTION parameters and values must be separated by the "|" (pipe) character. 

Examples:

PAUSE 2 USING 'PAUSE window with the APPS icon.' CAPTION 'PAUSE Command' ICON APPS

PAUSE 2 USING 'You can customize the button message!' CAPTION 'PAUSE Command' ICON
INFO BUTTON 'Your customized message here...'

-- Standard PAUSE Command with ICON

PAUSE 2 USING 'Message Text' +
CAPTION 'Caption Text' +
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ICON HELP OPTION +
BUTTON 'Button Text' +
|BACK_COLOR WHITE +
|MESSAGE_COLOR WHITE +
|MESSAGE_FONT_COLOR GREEN +
|BUTTON_COLOR WHITE +
|BUTTON_FONT_COLOR GREEN +
|TRANSPARENCY 255

-- Standard PAUSE Command with custom ICON

PAUSE 2 USING 'Message Text' +
CAPTION 'Caption Text' +
BUTTON 'Button Text' +
OPTION ICON_FILE path\directory\filename.bmp +
|BACK_COLOR WHITE +
|MESSAGE_COLOR WHITE +
|MESSAGE_FONT_COLOR GREEN +
|BUTTON_COLOR WHITE +
|BUTTON_FONT_COLOR GREEN +
|TRANSPARENCY 255

Note: Custom icon to be used in PAUSE option must be 16x16 pixels BMP file.

-- Multi-Line PAUSE Command

-- (CHAR(009)) = Tab Key (Indent)
-- (CHAR(013)) = Carriage Return

SET VAR vMsg = +
('Line 1:'+(CHAR(009))+(CHAR(009))&'Contents of Line 1'+(CHAR(009))+(CHAR(013))+ +
 'Line 2:'+(CHAR(009))+(CHAR(009))&'Contents of Line 2'+(CHAR(009))+(CHAR(013))+ +
 'Line 3:'+(CHAR(009))+(CHAR(009))&'Contents of Line 3'+(CHAR(009))+(CHAR(013))+ +
 'Line 4:'+(CHAR(009))+(CHAR(009))&'Contents of Line 4'+(CHAR(009))+(CHAR(013))+ +
 'Line 5:'+(CHAR(009))+(CHAR(009))&'Contents of Line 5'+(CHAR(009))+(CHAR(013))+ +
 'Line 6:'+(CHAR(009))+(CHAR(009))&'Contents of Line 6'+(CHAR(009))+(CHAR(013))+ +
 'Line 7:'+(CHAR(009))+(CHAR(009))&'Contents of Line 7'+(CHAR(009))+(CHAR(013))+ +
 'Line 8:'+(CHAR(009))+(CHAR(009))&'Contents of Line 8'+(CHAR(009))+(CHAR(013))+ +
 'Line 9:'+(CHAR(009))+(CHAR(009))&'Contents of Line 9'+(CHAR(009))+(CHAR(013)))

PAUSE 2 USING .vMsg +
CAPTION 'Caption Text' +
ICON APP +
BUTTON 'Button Text' +
OPTION BACK_COLOR WHITE +
|MESSAGE_COLOR WHITE +
|MESSAGE_FONT_COLOR GREEN +
|BUTTON_COLOR WHITE +
|BUTTON_FONT_COLOR GREEN +
|TRANSPARENCY 255
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-- Standard PAUSE Command with custom ICON with Themes

PAUSE 2 USING +
'Now you can add themes to PAUSE windows!' +
CAPTION 'New PAUSE Command' ICON INFO +
OPTION themename Longhorn

-- PAUSE Command with Meter Progress Bar

PAUSE 3 USING +
'PAUSE Command Text with More OPTIONS - Imagine the Possibilities!' +
CAPTION ' ' +
OPTION METER_VISIBLE ON +
|METER_VALUE .vProgress +
|METER_TYPE BAR3D +
|METER_BACK_COLOR WHITE +
|METER_BAR_COLOR NAVY +
|METER_FONT_COLOR RED +
|BACK_COLOR WHITE +
|MESSAGE_COLOR WHITE +
|MESSAGE_FONT_COLOR GREEN
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-- PAUSE Command with GAUGE Progress Bar

PAUSE 3 USING 'Calculating ... Please Stand By ...'  +
CAPTION '                    Pause 3 with Gauge '  +
ICON WINDOWS  OPTION GAUGE_VISIBLE ON  +
|GAUGE_COLOR RED  +
|GAUGE_INTERVAL 10  +
|MESSAGE_FONT_NAME VERDANA  +
|MESSAGE_FONT_SIZE 10  +
|MESSAGE_FONT_COLOR WHITE  +
|THEMENAME Steel Blue

1.1 OPTION Parameters

These parameters can be used to change the "look and feel" of a PAUSE window. In addition to the
parameters below, you can also alter the PAUSE Message, as well as add a Meter or Gauge Meter. 

Parameter Value Description
ICON_FILE value Specifies the external path and image name for the

icon (file size must be 16x16 pixels).
BACK_COLOR AQUA

BLACK
BLUE
CREAM
DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE
RED
SILVER
SKY BLUE
TEAL
WHITE
YELLOW

Changes the color of the WINDOW BACKGROUND
area. User can specify the integer value or type one
of the predefined values.

BUTTON_COLOR AQUA
BLACK
BLUE
CREAM

Changes the background color of the button.
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DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE
RED
SILVER
SKY BLUE
TEAL
WHITE
YELLOW

BUTTON_FONT_COLOR AQUA
BLACK
BLUE
CREAM
DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE
RED
SILVER
SKY BLUE
TEAL
WHITE
YELLOW

Changes the font color of the button.

TRANSPARENCY 0 - 255 Set the transparency to specify a layered window with
a translucent color. The transparency value specifies
the degree of translucency.

TOP value Moves the pause box location, in pixels, from the top
of the screen down.

LEFT value Moves the pause box location, in pixels, from the left
of the screen over.

THEMENAME value Specifies one of 86 pre-defined Themes, or a custom
Theme loaded into R:BASE. 

NOTE: All previously defined PAUSE commands which
are redefined to use Themes should be thoroughly
checked prior to putting into production as objects and
text may look substantially different.

1.1.1 Message

These parameters the message within the PAUSE window. 

Parameter Value Description
MESSAGE_COLOR AQUA

BLACK
BLUE
CREAM

Changes the color of the actual message.
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DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE
RED
SILVER
SKY BLUE
TEAL
WHITE
YELLOW

MESSAGE_FONT_COLOR AQUA
BLACK
BLUE
CREAM
DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE
RED
SILVER
SKY BLUE
TEAL
WHITE
YELLOW

Changes the color of message font.

MESSAGE_FONT_NAME value Specifies a font name for the message. Values
would consist of the fonts available on the
computer.

MESSAGE_FONT_SIZE value Specifies the font size.
MESSAGE_FONT_BOLD ON

OFF
Specifies if the message font is bold type. 

MESSAGE_FONT_ITALIC ON
OFF

Specifies if the message font is italic type.

MESSAGE_FONT_UNDERLINE ON
OFF

Specifies if the message font is underline type.

MESSAGE_FONT_STRIKEOUT ON
OFF

Specifies if the message font is strikeout type.
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1.1.2 Meter

These parameters will display a meter within the PAUSE window. 

Parameter Value Description
METER_VISIBLE ON

OFF
Displays a meter to show a progress in percentage
values.

METER_TYPE NORMAL
BAR3D
LED

Three meter options are available.

METER_VALUE 0 to 100 Specifies the percentage to display the meter
progress.

METER_BAR_COLOR AQUA
BLACK
BLUE
CREAM
DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE
RED
SILVER
SKY BLUE
TEAL
WHITE
YELLOW

Specifies the color of the meter bar.

METER_BACK_COLOR AQUA
BLACK
BLUE
CREAM
DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE
RED
SILVER
SKY BLUE

Specifies the meter background color
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TEAL
WHITE
YELLOW

METER_FONT_COLOR AQUA
BLACK
BLUE
CREAM
DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE
RED
SILVER
SKY BLUE
TEAL
WHITE
YELLOW

Specifies the color of the meter font.

METER_MAX_VALUE 0 to 100 Specifies the maximum percentage to display the
meter progress.

METER_COLOR1 AQUA
BLACK
BLUE
CREAM
DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE
RED
SILVER
SKY BLUE
TEAL
WHITE
YELLOW

Specifies the color of the meter when using three
color segments (green, yellow, red)

METER_COLOR2 AQUA
BLACK
BLUE
CREAM
DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE

Specifies the color of the meter when using three
color segments (green, yellow, red)
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RED
SILVER
SKY BLUE
TEAL
WHITE
YELLOW

METER_COLOR3 AQUA
BLACK
BLUE
CREAM
DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE
RED
SILVER
SKY BLUE
TEAL
WHITE
YELLOW

Specifies the color of the meter when using three
color segments (green, yellow, red)

METER_COLOR_OFF Sets the color off when using three color segments.

Example:

PAUSE 3 USING +
'PAUSE Command Text with More OPTIONS - Imagine the Possibilities!' +
CAPTION ' ' +
OPTION METER_VISIBLE ON +
|METER_VALUE .vProgress +
|METER_TYPE BAR3D +
|METER_BACK_COLOR WHITE +
|METER_BAR_COLOR NAVY +
|METER_FONT_COLOR RED +
|BACK_COLOR WHITE +
|MESSAGE_COLOR WHITE +
|MESSAGE_FONT_COLOR GREEN

1.1.3 Gauge Meter

These parameters will display an oscillating meter within the PAUSE window. 



All About The PAUSE Command12

Copyright © 1982-2011 R:BASE Technologies, Inc. All rights reserved.

Parameter Value Description

GAUGE_VISIBLE ON
OFF

Displays an oscillating progress gauge.

GAUGE_COLOR AQUA
BLACK
BLUE
CREAM
DARK GRAY
FUCHSIA
GRAY
GREEN
LIME
LIGHT GRAY
MAROON
MEDIUM GRAY
MINT GREEN
NAVY
OLIVE
PURPLE
RED
SILVER
SKY BLUE
TEAL
WHITE
YELLOW

Specifies the color of the progress gauge. 

GAUGE_INTERVAL 10-100 Specifies the speed interval of the oscillating progress
gauge.

Example:

PAUSE 3 USING 'Calculating ... Please Stand By ...'  +
CAPTION '                    Pause 3 with Gauge '  +
ICON WINDOWS  OPTION GAUGE_VISIBLE ON  +
|GAUGE_COLOR RED  +
|GAUGE_INTERVAL 10  +
|MESSAGE_FONT_NAME VERDANA  +
|MESSAGE_FONT_SIZE 10  +
|MESSAGE_FONT_COLOR WHITE  +
|THEMENAME Steel Blue
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2 Feedback

Suggestions and Enhancement Requests:

From time to time, everyone comes up with an idea for something they'd like their software to do
differently. This is true of all applications, no less R:BASE. 

If you come across an idea that you think might make a nice enhancement to R:BASE, your input is
always welcome. 

Please submit your suggestion and/or enhancement request to the R:BASE eXtreme 9.1 Developers'
Corner Crew ( R:DCC) and describe what you think might make a nice enhancement. In R:BASE
eXtreme 9.1, the RBG9 R:DCC Client is fully integrated to communicate with the entire development
team of R:BASE eXtreme 9.1. From the main Menu Bar, choose "Help" > "RBG9 R:DCC Client".

Unless additional information is needed, you will not receive a direct response. You can periodically
check the status of your submitted enhancement request accordingly. 

Reporting Bugs:

If you experience something you think might be a bug in R:BASE, please report it to the R:BASE
eXtreme 9.1 Developers' Corner Crew. In R:BASE eXtreme 9.1, the RBG9 R:DCC is fully integrated to
communicate with the entire development team of R:BASE eXtreme 9.1. From the main Menu Bar,
choose "Help" > "RBG9 R:DCC Client".

You will need to describe: 

· What you did 
· What happened 
· What version and build of R:BASE you have 
· Any error messages R:BASE gave 
· What kind of computer you have 
· Which operating system you're using 
· Anything else you think might be relevant 

Unless additional information is needed, you will not receive a direct response. You can periodically
check the status of your submitted bug accordingly.
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3 Useful Resources

. R:BASE Home Page: http://www.rbase.com

. R:BASE eXtreme Home Page: http://www.rbaseextreme.com

. Up-to-Date R:BASE Updates: http://www.rupdates.com

. Sample Applications: http://www.rbasecommunity.com

. Building Syntax for PROPERTY Command: http://www.rbase.com/property

. Building Syntax for GETPROPERTY Command: http://www.rbase.com/getproperty

. General R:BASE Syntax: http://www.rsyntax.com

. Technical Documents - From The Edge: http://www.razzak.com/fte

. More Sample Applications:   http://www.razzak.com/sampleapplications

. Education and Training: http://www.rbaseuniversity.com

. Upcoming Events: http://www.rbase.com/events

. R:BASE Beginners Tutorial http://www.rtutorial.com

http://www.rbase.com
http://www.rbaseextreme.com
http://www.rupdates.com
http://www.rbasecommunity.com
http://www.rbase.com/property
http://www.rbase.com/getproperty
http://www.rsyntax.com
http://www.razzak.com/fte
http://www.razzak.com/sampleapplications
http://www.rbaseuniversity.com
http://www.rbase.com/events
http://www.rtutorial.com
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